Programming:
Fabrice Bourgeois
Nicolas Bronnec
Sylvain Gubian
Xavier Oudin
Gilles Pommereuil
Cedric Rossi
Lionel Tirant
Anthony Garcia
Arnaud Aune
Laurent Eyraud
Renaud Chassande

Sound Design:
Jean-Michel Blanchet

Graphics:
Mickael Acoca
Yannick Bonnefoy

Manual:
Frédéric Brun
Tom Healy
Yuji Sano
Takashi Uesugi
Sven Steglich
Till Pape
Gilles Pommereuil
David Poncet

Special thanks to:
Vanessa Giraudet, Anissa Brazane, Celestín Kouate, Nicolas Dupont, Régis Monte, Stéphane Boissieux,
Benjamin Abrial, Katsunori Ujifié, Takashi Uesugi, Mitsuru Sakaue, Frank Orlich, Bryan Borcherds, Vincent
Nonnenmacher, Christophe Martin de Montagu, Houston Haynes, Franck Selbmann, Dominique Coussy, Tyson
Thomas, Alessandro Camanini, Vincent Gagnon.
# TABLE OF CONTENTS

## First steps
- INSTALLATION.................................................................................................................................5
- REGISTRATION.................................................................................................................................6
- QUICK START.................................................................................................................................11
- COMPOSITION ASSISTANT...........................................................................................................23

## Basic Use
- THE EXPLORER..........................................................................................................................27
- THE RACK ...................................................................................................................................29
- THE MIXING TABLE.......................................................................................................................31
- THE SEQUENCER.........................................................................................................................35
- KEPLER .......................................................................................................................................39
- STATIC MODE COMPOSITION......................................................................................................41
- USING SAMPLES............................................................................................................................43
- LOADING-SAVING..........................................................................................................................47
- AUDIO EXPORT.............................................................................................................................51

## Advanced Use
- MIDI CONTROL AND SYNCHRONIZATION..................................................................................55
- IMPORTING MIDI FILES................................................................................................................57
- THE PIANO ROLL..........................................................................................................................59
- REWIRED ....................................................................................................................................67
- THE HALL ...................................................................................................................................69
- CONFIGURATION ........................................................................................................................75
- KEYBOARD SHORTCUTS...............................................................................................................79

## Instruments
- SYNTHESIZER BASICS....................................................................................................................81
- ARSENIC.......................................................................................................................................83
- BASS 52.........................................................................................................................................89
- EQUINOXE....................................................................................................................................92
- ORPHEUS .....................................................................................................................................95
- GMSynth.......................................................................................................................................101
- SHADOW ......................................................................................................................................104
- DRUM MACHINE BASICS.............................................................................................................111
- TSUNAMI ......................................................................................................................................113
- METEOR .......................................................................................................................................119
- PSION ..........................................................................................................................................121
- PUMA ..........................................................................................................................................123
- HORK ..........................................................................................................................................125
- SAMPLE MODULES BASICS.........................................................................................................127
- EZTRACK......................................................................................................................................128
- H3OPLUS......................................................................................................................................132
- SCRATCH ......................................................................................................................................137

## Effects
- EFFECTS BASICS............................................................................................................................139
- CHORUS.........................................................................................................................................141
- COMPRESSOR...............................................................................................................................142
- DISTORTION ................................................................................................................................146
- DUAL DELAYS...............................................................................................................................147
- FLANGER ......................................................................................................................................150
- LPFILTER......................................................................................................................................151
- REVERB........................................................................................................................................152
- RING MOD....................................................................................................................................154
- SEQ FILTER..................................................................................................................................155
- VOCODER.....................................................................................................................................157
INSTALLATION

Warning: before running the Storm Music Studio installer, please temporarily disable any virus protection utilities running in the background, as they may cause problems with the installer.

Minimum requirements

In order to use STORM Music Studio 3.0, you must have a computer equipped with the following:

<table>
<thead>
<tr>
<th>WINDOWS</th>
<th>Mac OS X</th>
</tr>
</thead>
<tbody>
<tr>
<td>• Pentium III 600 MHz</td>
<td>• G3 800 MHz</td>
</tr>
<tr>
<td>• Windows 98 SE / 2000 / XP</td>
<td>• Mac OS X version 10.3.1 or later recommended</td>
</tr>
<tr>
<td>• 256 MB of RAM</td>
<td></td>
</tr>
<tr>
<td>• Any DirectX, ASIO compatible soundcard, or CoreAudio for Mac OSX</td>
<td></td>
</tr>
</tbody>
</table>

Installation

Storm 3.0 is shipped with 2 CD's. The first CD-ROM contains the Windows installer whereas the second CD contains the Mac installer.

WINDOWS:

• Insert the Storm CD-ROM into your drive
• If the installer does not automatically launch after CD-ROM insertion, use the Windows Explorer to browse the CD-ROM contents and double click on Setup_PC.exe.
• Then follow the instructions that appear on the screen.

Mac OS X:

• Insert the Storm installation CD-ROM into your drive
• Double-click on the installation program called Storm3.pkg. The setup program will ask you for a system administrator password if needed.
• Then follow the instructions that appear on the screen.

Technical support

Before calling or writing to our technical support staff, be sure to do the following:

• Make sure that you have registered your license number with Arturia.
• Check to see if the information you need is not already contained in:
  • The Support section of our web site, located at: [http://www.arturia.com/en/support.lasso](http://www.arturia.com/en/support.lasso)
  • Arturia Forums: [http://forums.arturia.com](http://forums.arturia.com)
  • Storm Music NewsGroup: [http://groups.yahoo.com/group/storm_music](http://groups.yahoo.com/group/storm_music)
• Have your serial number and key available to you. Write down the hardware and software configuration you use with Storm (processor, RAM, OS, sound card).
• Choose one the following methods to get in touch with Arturia:
  • E-mail: support@arturia.com
  • Fax: +33 (0)4 38 02 05 25
Remark

Registration only concerns the full version of Storm. It unlocks access to the software and allows registered users to benefit from supplementary services such as downloading updates and new modules.

If you are using a trial version of Storm, or a “light” version that you received bundled with a sound card for example, this procedure does not concern you, unless you upgrade to the full version. Buying procedures for the software and getting a license number can be found in the Help > About Storm menu.

To have full and definitive use of Storm, you need to register with Arturia. This registration will allow you to obtain an unlock-key which is essential to continue using Storm after your first 20 tries. Here is the procedure to follow:

When the program is launched, a window will ask you to enter the license number of your program, your first name and your last name.

Recopy the number on the sticker on the case of the Storm CD-ROM, or the one sent to you by e-mail by Arturia technical support. This number is essential in the registration procedure.
English lesson

For the users installing Storm in English but for whom it is not their mother tongue, be careful not to invert your First Name and Last Name:

<table>
<thead>
<tr>
<th>ENGLISH</th>
<th>FRANÇAIS</th>
<th>DEUTSCH</th>
<th>DUTCH</th>
<th>ITALIANO</th>
<th>ESPAÑOL</th>
<th>PORTUGÊS</th>
</tr>
</thead>
<tbody>
<tr>
<td>First Name</td>
<td>Prénom</td>
<td>Vorname</td>
<td>Voornaam</td>
<td>Prenome</td>
<td>Nombre de pila</td>
<td>Prenome</td>
</tr>
<tr>
<td>Last Name</td>
<td>Nom</td>
<td>Nachname</td>
<td>Achternaam</td>
<td>Cognome</td>
<td>Apellido</td>
<td>Sobrenome</td>
</tr>
</tbody>
</table>

Click next, now you have 3 choices:

First possibility

Click on the Now button.

A form will appear asking you to provide certain information on top of your first name and last name: address, e-mail address, etc.
Click on **Next**. On the following screen you have two registration options:

- **First name**: Cedric
- **Last name**: Rossi
- **Address**: 1, rue de la Gare
- **Postal code**: 38950
- **City**: Saint Martin le Vieux
- **Country**: France
- **Telephone no**: 
- **E-mail**: cedric@arturia.com

- **I wish to receive the Arturia newsletter**

Click on **Yes** if your computer has an Internet connection, you will automatically get the unlock key and the procedure will only take a few seconds. In this case, verify that your internet connection is currently active and click on "Yes".

If you click on "No" we will indicate other methods to get the key without an Internet connection.
• The computer where you have installed Storm is connected to the Internet.

Click on this option if you have an Internet connection and it is currently active. In this case the registration is automatic and you have nothing else to do.

In this case, the Arturia server will send the program its key which is essential for Storm to run.

During the connection, the only information received by Arturia is that which you have previously entered (license number, name, first name, address, e-mail). Nothing else is touched on your hard drive.

• The computer is not connected to the Internet.

Click on this option if the computer on which you are installing Storm does not have an Internet connection.

The following screen will suggest that you save a text file that you can print and send to Arturia. Your unlock key will be sent to you within 4 days of the receipt of your mail. You can also send this file by fax or e-mail in order to get your unlock key sooner (postal address, fax and e-mail address are indicated in the file).

The text file to send to Arturia

When you have received your key, you can then relaunch Storm, and at startup, select the second choice described underneath: You already have your unlock key.
Second possibility: You already have your unlock key.

This is the case if you are reinstalling your software or you have received your unlock key by postal mail. You just need to provide this key to unlock Storm and have all its functionalities. Attention, this key will work on one computer with a precise operating system. If reinstalling Storm, you will need to get another key from Arturia if in the mean time you have changed computer or operating system.

Third possibility: You don’t want to register right away.

For this click on the Later button. You have 20 tries before the software is locked and will continually ask for the unlock key. If this happens, the only choice you will have is to click on the Now button. We advise that you register as soon as possible, especially if you count on doing so by postal mail if you don’t have an Internet connection. Once the procedure is fully complete, it will be proposed that you save a file with all of the registration information. We highly recommend that you save and print this just in the case you might need to reinstall the application.

A little jargon

To install Storm, the software needs 2 numbers that while constructed in a similar manner do not have the same use. To avoid confusion:

- The license number is on a white sticker stamped with the Arturia logo, and stuck to the installation CD-ROM case. This number is to identify you as the user (and owner, as stipulated in the license agreement) of Storm.
- The unlock key, which is calculated during the installation, and which will depend on the license number, is used to protect the license number. It prevents the installation of Storm on several machines or different operating systems, when outside of the cases agreed in the license.
In this chapter, you are going to compose your first song using the basic functions of Storm.

Building a studio, playing in real time, recording settings and saving compositions are operations that will no longer hold any secrets after you have read this first chapter.

Creating a Studio

When you launch Storm, you will find yourself in front of the studio screen.

In the central part of the screen, you can see two vertical sections of a dark color, separated by metallic bars. This is the rack in which you will place the effects and instruments that you have chosen.

In the section on the left called the explorer, you will see a number of tabs which present resources that can be loaded into the studio. The first tab opens the virtual instrument library. Use the scroll bar on the right of the explorer to navigate.

The second tab opens the effects library. Again browse with the scroll bar.
Storm, a real “à la carte” studio

The main idea of Storm is the creation of a compositional environment comparable to that of professional composers. In the studio, the professionals put synthesizers, drum machines, effects, etc, on a rack (the metallic structure in the studio). The studio is created in relation to the style of music that they wish to create, just like Storm.

- From the library on the left, choose the sound module called Arsenic and using “drag and drop”, put it onto the virtual rack. It will take the first empty space in the rack.

Drag and drop onto the rack.

- In the same way, next choose the Meteor and H3Oplus modules. You have just built the first part of your studio.
- From the library on the left, choose the sound effect called Dual Delays. As you have previously done, drag and drop it onto the virtual rack.
- Repeat the same operation for the Chorus and Reverb effects.

You can drop as many instrument modules (or effects) as you wish to the rack.

The configuration of the studio you have just built.
Unlimited modules in the rack?

As mentioned above, Storm allows an unlimited number of synthesizer and effect modules in the studio but to be more precise: the capacity of modules is directly related to the power of the processor in your computer. The more powerful the processor, the more modules you can place! Certain modules are more demanding than others (an icon placed on the right of each module indicates the amount of CPU power used).

And there it is, you have just built your first studio. Now let's go on to the second phase, composition in real-time.

Composing in real time

Your studio is ready. In a few moments, you will discover the infinite possibilities that Storm software offers in terms of musical creation.

At first sight, the screen you have in front of you looks fairly complicated. There are lots of buttons, sliders, dials, and geometric shapes. But don't worry, everything is simpler than it seems and soon all its secrets will be revealed.

- Start by clicking on the arrow located at the top left of the screen. This is the PLAY button that commands all of the sound modules. You will hear a looped melody.

Click on the PLAY button

- Click on the LOOP button to activate the selection of the loop. Next set the loop length by dragging the green bar above the sequencer tracks.

- In the lower zone, there is a stereo mixing table. This table controls the output of different sound modules. Click on the MUTE button of the master. The sound stops immediately. Click again and try out the various sliders that control the output levels of the sound modules.

The mixing table lets you set the output level for each module.

- Click on the MUTE button of modules 2, 3 and 4, we are now going to learn a little about our first instrument: Arsenic.
- The zone on the left lets you select the current pattern. When you click on the numbers and letters of the pattern selector, you change the melodic theme played. Try to program themes A11, A12, B21 in succession.
Click on the Pattern selector.

Later on, you will be able to compose your own patterns, but for the moment, let's see how to manage the sound of this module by using one or two effects.

Using effects

On the left hand limit of the mixing table, you will see 3 icons corresponding to the three states of the mixing table. This will allow you to access the dosing of effects, equalization and detachment of the mixing table.

The three mixing table icons

- Click on the **FX** icon to make the effect setting extension appear.
- Choose the **Dual Delays** effect by clicking on the LCD display in Arsenic.

Choose the Dual delays effect.

- Click on the potentiometer to dose the output from the synthesizer going to the effect.
- Keep the button pressed down and move the mouse up.

Click on potentiometer a, sending the sound from the instrument to the Dual Delays effect.
Dual Delays creates a stereo delay effect between the left and right speakers of your machine.

- To have a better idea of how it works, increase the amount of the delay on the left loud speaker by clicking on the LEFT feedback dial of the left channel.

  Increase the delay on the left speaker.

- The number 1 instrument is still the only one turned on. Thus, it is the only one whose sound you can hear. Now let's try to apply the second effect to the sound. For this choose Chorus in the second display and click on the potentiometer to increase the effect dosage in the sound from Arsenic.

  Click on the Lev. potentiometer of the second effect send

**Linking effects**

You can link the sound effects between each other. So for example, the output from a synthesizer can be sent to the delay which will then be directed to the chorus and then on to the reverb. It is nonetheless essential that you avoid re-injecting an effect into itself. This will bring about a saturation of the sound.

Directing the sound from chorus to the reverb.
The effect sends on the rack

It is possible to have the effect sends on the rack, on the right of each instrument and effect module. To do this go to the menu View > rack > effect control. Opening these effect sends is the same as in the mixing table extension.

![Effect Sends on Rack](image)

Turn the effect send potentiometers

Using the equalization

It is possible to set the equalization of a sound coming from a synthesizer (or an effect) with the equalizer section on the mixing table:

- To have the equalizer section appear, click on the icon on the left of the mixing table.
- On the equalizer in the Arsenic section, try turning the different potentiometers to appreciate the changes reflected in the sound from the synthesizer.

![Equalizer Section](image)

The different equalizations

The equalizer section lets you increase or diminish high, medium and low frequencies. The **FREQ** potentiometer finely sets the position of the medium frequency band (deeper or higher), for more precision in the equalization.
Recording your first composition

We are now going to see how to record in .stm format. This is the internal format in Storm which allows us to record real-time manipulations.

- Lets start by opening the outputs of all of the modules. To do this, click on the MUTE buttons of the 2nd and 3rd instruments on the mixing table.
- Click on the button on the far left of the control bar which sets the immediate return of the cursor to the beginning of the song. You can equally click on the upper zone of the sequencer, where the graduations by bar and group are displayed to bring the cursor back to the desired position.

![Come back to the beginning of the group of bars by moving the cursor with the mouse.](image)

- Click on the button. you should see a loop bar appear which corresponds to the loop programming mode. Drag this bar across the whole of group 1 so that the cursor runs indefinitely (in a loop) over this group.

![Group 1 with the cursor and loop above.](image)

- To record, click on the button which is placed on the control bar at the top left of the screen.
- Click on the play button . The cursor crossing the sequencer underneath sweeps the squares of the sequencer causing them to change color. This signifies that the manipulations made during the bars corresponding to each of the squares are recorded.

![Click on the Rec button. The sequencer squares change color.](image)

- To be convinced, modify potentiometers and patterns during the recording. While re-crossing the modified bars, you will notice that the controllers move in the same manner that they did when you first modified them. Small horizontal lines will also appear on the sequencer lines: they indicate a pattern change on a module or the recording of notes in MIDI.
- When you have created a composition that you wish to save, click on the save icon in the toolbar, or use the command Save in the File menu. A window will open and suggest a name, destination, and format for the file to be saved.
Select the folder in which you wish to save your song

- When you are in the desired folder, click on Save. Your first Storm song is now on your hard drive.

Exporting an audio file

We saw how to create a studio, how to play in real-time while modifying the patterns and controllers, how to apply effects to the sounds. We have also seen how to save a song as .stm. We will now see how we can save a song as a WAV or AIFF file.

You have two options:

- Use the menu option File > Audio Export.
- Use the recorder icon in the toolbar.

If you use the Export option, a window will prompt you for the desired audio format and which section you wish to export.

If you use the recorder:

- To make a recording, you must open the recorder by clicking on the recorder icon which is found in the toolbar at the top of the screen.
- The recorder is now open. It is conceived in a manner which allows the recording of one instrument, or the recording of numerous instruments independently of one another and the recording of the master mix (all studio tracks together). We are going to record the sound from synthesizer 1. To do this, click on the first button of the recorder to activate the recording of this track.
The recorder.

- The recorder can perform a recording fixed between two bar numbers. Select a loop length by clicking on the button or select the parts of the sequencer tracks that you wish to record. Next click on the Record button at the bottom of the recorder to begin the recording.

- The recording begins and a dialog indicates the advancement of the recording. This will automatically stop at the end of the selection. A tape with the name of the module appears in the Current Song folder in the sample library.

A tape with the name of the module appears in the Current Song folder in the sample library.

Recording formats

There are two save formats in Storm: the formats WAV, and AIFF. These formats are completely different to the .stm internal format. For the first two it is only audio which is saved, whereas the .stm format memorizes the movements of controllers, patterns, sliders, etc.).
Using samples

We have just created two sound samples. These samples, will appear in the sample library and can be used directly in the studio. Storm offers vast possibilities for the use and management of samples. Here we are going to talk about one of them.

- Instrument number 3, named H3Oplus, allows us to play samples in a loop. Begin by using drag and drop to move what you have just recorded to the first track of the synthesizer.
- Mute the other instruments by clicking on MUTE buttons 1 and 2 of the mixing table. You are now hearing a loop of the first 4 bars of the sample you have just recorded.
- We will now add some more samples by using to the sample library. Open the sample library by clicking on the Samples tab in the explorer.

Click on the Samples tab in the explorer.

- Storm is provided with a base of several hundreds of samples in the sample library. Click on the folder Installed sample kits. Here you have a choice between a wide range of instruments. Select the library hip_hop/rhythm. This library contains typical Hip Hop samples. By drag and drop, move the sample called hip_hop_drums onto track 2 of H30plus.
- Before finishing, you may wish to discover the real-time time-stretching options that Storm offers. To do this, increase the tempo on the transport bar. You could also try modifying the tone of samples by using the Kepler module. Click on the to use this module.
• Next click on the spheres which make up a circular network. Each one corresponds to a different tone, and their chaining is normally applied to samples.

*Click on the spheres to change the tone.*

• Play with the tempo, the sample speeds are increased or decreased without modifying their height.

*Change the tempo.*

**About samples**

You can import samples into Storm in the following formats: WAV, AIFF or MP3. The system will handle all of these file formats in the same manner.

Storm automatically adapts the tempo and tone of each imported sample to the tone and tempo of the current studio. The automatic sample tempo modification is called time-stretching. The automatic sample tone modification is called pitch-shifting.
Upon launch of Storm, you can:

- Discover the Storm environment: the synthesizers, the effects, the mixing table and the sequencer. This will allow you to quickly understand the general manner in which Storm works.
- Use the composition assistant: you can pick an assistant in the style of your choice (Dance, House, Hip Hop, etc.). This assistant will be very useful if you have never composed before or you wish to compose in a style that you are not familiar with.
- Open a song: demonstration songs are provided with the program. They will allow you to see what you can do with the software and give you a few good examples of professional quality.
- Compose freely: pick your own instruments and effects and go for it.

If you don’t wish to see this window on startup, simply click on Don’t show this window when Storm is launched (you can also do this from the Settings > General menu).
There are several ways to launch the Assistant:

- You can choose to use a composition assistant in the startup window described above.
- You can also activate it by selecting it in the menu File > Composition Assistant.
- The button on the toolbar is another method.

When the Wizard is launched, it offers you a certain number of musical styles represented by icons: House, Electro Pop, R’n’B, Hard Rock, Tribal Trance, Ambient, Drum & Bass, Jazz Funk, Dub/Reggae, Dance, Hip Hop (other composition assistant styles can be downloaded from our web site).

First step: choice of musical style for the Assistant

Choose the style of music that you want by clicking on the icons. You will see information relative to the selected tutorial: the style of music, the number of steps for the composition of the song, a musical extract (click on the “speaker” icon) and a reduced image of the studio which will be proposed for your song.

Once have decided on the musical style, click on the Start button to begin composing your song.
Using the Assistant

Once you have decided on the style of music, you will find a series of buttons and icons allowing you to easily advance in the composition of your song in the second window of the Assistant:

![Wizard Dance](image)

The Assistant window which will guide you step by step in the composition of your song.

At the top of the window, a bar indicates how far you have advanced in the composition of the song:

- The sections of the song are identified by a title, and are numbered. They are of different lengths: the bigger the section, the more programming steps there are.
- As the Assistant continually advances, the sections will be colored, meaning that the steps have been completed. You will find the same titles and colors in the Storm sequencer. The bar of the Assistant is a miniature sequencer.
- You can move to the different parts of the song already completed by moving the red cursor above the desired section or by clicking on Previous.

On the left, a series of icons tell you what type of step you are currently on:

- Confirm a choice or an operation
- Choose a pattern
- Record a modification of a parameter or potentiometer
- Listen to a passage
The Tip button can also (depending on the step) give you a description of a precise point or a more general subject concerning the style of the song.

To exit the Wizard, you can perform any of the following steps:

- Simply click on the Cancel button in the window.
- Create a new studio
- Load a new song.
- Quit Storm.

After one of the above steps, the program will ask you if you wish to save the position of the Assistant. This is not systematically saved with the Storm file that you are composing:

- If you answer no, you will lose the ability to be able to work on your song again with the Assistant. To later work on the song, you're on your own with the sequencer…!
- If you answer yes, you will be able to do this. When you open the Storm file, you will be able to continue where you left off or even go back along the steps.
The Explorer is found on the left of your virtual studio. It contains all of the base modules for the creation of music: instruments, effects, samples.

It contains four sections. To go from one to another, just click on the corresponding tab.

The sections are:

- **The instruments**
  These are the “sound generators” for your songs.

- **The effects**
  These let you modify the sound from an instrument. All of the instruments and effects are described in detail in Chapters 4 and 5 of this manual.

- **The ReWire instruments**
  If Storm has been launched as a ReWire Mixer, and if ReWire Instruments are present in your system, they will be listed here. See the ReWire chapter for more information.

- **The sample bank**
  This lists all of the samples that you can use in the Storm sample readers, as well as the audio tracks that you have recorded. See the Chapter Using samples for more information.

This sections holds a particular toolbar, identical to the one contained in the section on Hall Navigation.
Instruments and effects (what we call “modules”) are presented in the following form:

- The top left, the module name.
- The top right, the type of module (for example Synthesizer, Drum Machine or Effect).
- The bottom right, a small display called CPU. This represents an estimation of the power required for this module. You can thus see that Orpheus is much more demanding on resources than Arsenic.

To use a module in your song, you must insert it into the rack. For this, drag and drop it to the desired location, or click on the icon.

Note that you can hide the Explorer by selecting the menu: View > Explorer > Hide.
The Rack allows you to stock instruments and effects that you are going to use in your song, just like a rack in the real world. The main difference is that there is no limit aside from the power of your computer, to the number of effects and instruments that you can use!

To add a module to the rack, just drag and drop from the Explorer. You can also select a module in the Explorer and click on the button. It is thus possible to place the modules where you want on the Rack simply by drag and drop.

To remove a module present on the Rack, perform a right-click (control-click for Macintosh) on it and select Remove module. If you have no space left to add more modules, right-click anywhere on the Rack and select Add a line or Add a column. If your Rack is too big to see its entirety on the screen, you can move using the scroll bar or the Minirack (see following section).

You can see the effect send controls by selecting the menu: View > Rack > Effect controls. This will make an effect settings section appear on the right of each module, identical to the one described in the chapter Mixing Table. You can use either use this one or the section of the mixing table to the same ends.
The Minirack gives you an overview of your Rack.

The Minirack gives you an overview of your Rack. All of the modules that you have installed in the rack will be represented in a reduced scale.

It also contains a section showing the currently visible part of the Rack. You can drag this selection to quickly see another part of the Rack.

Finally, if you connect a module to an effect, the link between the two will temporarily blink in the Minirack.

Visualization of effect sends.

If necessary you can hide the Minirack by clicking either on the arrow on the right (which will give more space to the mixing table), or the arrow above (which will make the Explorer bigger).

Click on one of the arrows to hide the Minirack.
The mixing table is found at the bottom of the composition window. It controls the volume for each of the instruments and effects in your song as well as the overall volume. You also have a semi-parametric equalizer available for each track.

<table>
<thead>
<tr>
<th>EQ</th>
<th>FX</th>
</tr>
</thead>
<tbody>
<tr>
<td>High</td>
<td>Low</td>
</tr>
<tr>
<td>Mid</td>
<td>Low</td>
</tr>
<tr>
<td>Low</td>
<td>Low</td>
</tr>
</tbody>
</table>

The mixing table is composed of three sections. By default, only the volume is visible, but two buttons on the left allow access to the other sections. The **EQ** button opens the effect send section, while the **FX** opens the equalizers. The third button, **MUTE** opens the mixing table in an independent window.

You can also hide it by clicking on the arrow pointing down above it.

*Click on the arrow to hide the mixing table.*

These options are also available in the menu View > Mixing table.

It is also possible for you to change the order of the sections on the mixing table, simply drag them where you want. This at the same time changes the track order on the sequencer.
The volume section.

This section is composed of a section for each instrument and effect contained in your song. If there is not enough space to display all of them, a scrolling bar appears below. Completely to the right you will see a section called MASTER, which corresponds to the global volume of your song.

In each section we find

- At the bottom, the name of the instrument. You can rename it by double-clicking on it; this will also update the name in the Rack.

  ![Instrument Name]

- Above, a fader which sets the instrument volume.
- On both sides of the fader, displays indicating the volume of left and right channels.

  ![Fader and Displays]

- Above, a potentiometer sets the panoramic of your instrument; completely to the left it will only allow sound from the left track past; fully to the right, only sound from the right; centered (the default position), the two tracks are represented equally.

  ![Panoramic Settings]

**Tip**

Try not to leave the panoramic centered for all of your instruments! Your final mix will have more of a “stereo” sound...

- Finally, the MUTE button lets you completely cut the volume from this track, while the SOLO button cuts the volume for all of the other tracks to only hear this one.
Setting effect sends

The effects section.

If you have used effect modules in your song, you can define here how to affect them to instruments or each other.

You can affect up to three effects to a mixing section. For this, click on one of the three effects selectors: a menu appears, allowing you to choose one of the effects in your song.

Choose an effect.

Linking effects

You can also route effects to each other. Effects have their own mixing section so you can direct the sound from an effect to another... Attention not to create loops!

On the right of this selector, a potentiometer allows you to define the level of effect sent. Completely to the left, no sound is sent to the effect, and completely to the right, all of the sound is sent.

Set the level to be sent.

The **PRE** button determines if the sound is sent to the effect before passing through the volume section or not.

In other terms, if **PRE** is active, the instrument sound is sent to the effect without taking settings on the volume section into account. Even if the instrument volume is set to zero, it will still be sent! This is very useful if you want only the sound modified by the effect in your mix.
Finally, the equalizer section lets you influence the sound of your instruments. For this, you need to activate it by clicking on the button. You can independently set the high frequencies (in the upper HIGH part), the low frequencies (in the LOW part), and the medium (in the MID part).

In each of these sections, the potentiometer at the middle signifies that the sound in this frequency range has not been modified; to the right it is increased, and reduced to the left.

In the MID part you can also set the frequency upon which you wish to act. By turning this potentiometer to the left you act only on the medium-basses, to the right on the medium-high.

*Use the FREQ potentiometer to set the frequency on which you wish to act.*
The Sequencer is the central nervous system for your song. It directs the instruments and effects, and allows you to record the evolution of your song.

The Sequencer

The different elements of Storms sequencer

The Sequencer is made up of three main parts:

- the control bar is used to move within the song and act in a global manner on the sequencer settings.
- the position bar indicates your current position in the song.
- the instrument tracks represent the location where your pattern variations are recorded, instrument or effect settings, etc.

the control bar

- Moves the cursor to the beginning of the song.
- Moves the cursor back by a group (or four bars).
- Moves the cursor forward by a group.
- Starts playback of the song from the current cursor position.
- Stops playback of the song.
  - 1 click: stops the song, the cursor remains in its current position.
  - 2 clicks: returns the cursor to the beginning of the loop (see below).
  - 3 clicks: returns the cursor to the beginning of the song.
- Triggers the recording mode. The recording will begin as soon as you click on the button. All of the parameters that you change will be recorded on the sequencer tracks (change of instrument pattern, of parameters like the filter, the volume, etc.).

- The tempo indicator (number of beats per minute). You can modify the tempo by clicking on one of the arrows on the indicator, or by double clicking and entering a new value on the keyboard.

- Cursor position (in minutes:seconds). You can modify this position by double clicking on the indicator and entering a new value.

- Cursor position (in groups:bars). You can modify this position by double clicking on the indicator and entering a new value on the keyboard.

- Loop indicator. The sequencer goes to “loop” mode when this button is active.

- The color indicator. When we record manipulations, the bars covered by the cursor change color. This makes it easier to find bars already recorded. This button will let you choose several colors so as to be able to class your different recordings by color. For this, just click on the button, and the recording color is automatically modified.

- Shuffle. Changes the rhythmic groove and delays the off beat rhythm on all modules. The more we drag the cursor to the right, the more the off beat rhythms are shifted.

### the position bar

By clicking and moving in the upper zone, you can define a loop. If the loop button on the control bar is active, Storm will return to the beginning of this loop as soon as it reaches the end. This will allow you for example to repeatedly listen to a part of your song so as to fine tune it.

**play a part of your song in a loop**

By clicking on one of the extremities of the loop, you can make it bigger or smaller. By clicking on the outside of the loop you can create another.

In the lower part of the position bar we find the positions expressed in groups and bars. The orange bars mark the groups while the small gray bars mark the bars. A group is an ensemble of four bars, while a bar is (by default) and ensemble of four beats.

**Position of the playback cursor in the song**

The large vertical bar represents the position of the cursor: it is the location in the song currently being played. You can click anywhere on the position bar to move this cursor.
The tracks

The instrument tracks represent the location where your pattern changes are recorded

You have one track for each instrument present in your Rack, one track for Kepler, and one master track. If you cannot see all of the tracks at the same time, a scroll bar will appear on their right. Underneath this scroll bar you will find four small magnifying glass symbols.

Zoom on the tracks

By clicking on the (+) magnifying glasses you zoom the display (either horizontally or vertically), and vice-versa with the (-) magnifying glasses. If you zoom vertically enough, above the names of each of the tracks you will find controls like those present on the mixing table. You can thus change the volume or the panoramic for a track, or use the Mute and Solo functions of the mixing table directly from the sequencer track for an instrument.

Reminder of mixing table functions

You will also find (although only on instrument tracks) a MIDI button and a scrolling list letting you choose the MIDI channel which controls this instrument. When the track is selected, the MIDI button becomes red, which signifies that this track can be controlled with a MIDI keyboard.

Assign a MIDI channel

The pattern indicators: When you are in Recording mode, the sequencer automatically records all of your pattern changes, which are indicated at the start of each bar by a small white rectangle containing the pattern number.
You can act on the tracks themselves with the contextual menu that appears with a right click (control-click for Macintosh) at the desired location. These actions always apply to at least a full bar for an instrument. If you wish to apply them to a larger selection, you can select the desired zone by clicking and dragging your mouse.

The actions available are as follows:

- **Mute/Unmute**: This function mutes the bars selected on the sequencer. The selected bars will be marked with a cross to signify that the mute is active. The instruments will automatically be muted on the selected bars when the song is played back. You can cancel this by reselecting Mute/Unmute on the muted bars.
- **Set bar tempo**: This menu lets you change the tempo of the selected bars.
- **Set bar length**: Here you can change the length of the bars selected on the sequencer (the unit being the semiquaver).
- **Set bar color**: Here you can change the color of the bars selected on the sequencer during a recording. You can in the same manner use the button situated on the control bar, before a recording.
- **Edit**: Opens the Piano Roll on the selected bar.
- **Copy / Cut / Paste**: These three options let you copy / cut and paste a selection on the sequencer. It is also possible to access these functions with the keyboard shortcuts Ctrl+C / X or V or via the Edit menu.
- **Create a MIDI sequence**: Creates an empty MIDI sequence in the selected bars. You can then record MIDI events inside (what you play on the keyboard for example).
- **Convert to MIDI**: Convert the selected bars to a MIDI sequence. If the bars contain patterns, the pattern notes are also converted to MIDI notes.
- **Record in Static mode**: see the chapter Static mode composition.
- **Make an audio recording**: This function lets you make an audio recording of what is selected on the sequencer. See the chapter Audio export.
**KEPLER**

**The Kepler module**

Kepler is one of the most original modules in Storm: its function is to manage the harmony of a song.

To access Kepler, you can either click on the icon in the toolbar, or select the menu **View > Kepler**.

To ensure the harmony of a song, all of the modules must function according to the same tone. Kepler allows you to define this tone, and even program a sequence of tones.

![The Kepler module.](image)

**How does Kepler work?**

There are two concentric circles which are made up of spheres. Each sphere represents a tone: on the inner circle the tones are minor, on the outer circle the tones are major. This is what we call a cycle of fifths: each of the spheres is one fifth from the one that follows (following the hands of a clock).

The tones are presented in the Anglo-German nomenclature, which today is the most widely used.

<table>
<thead>
<tr>
<th>French system</th>
<th>DO</th>
<th>RE</th>
<th>MI</th>
<th>FA</th>
<th>SOL</th>
<th>LA</th>
<th>SI</th>
<th>Major</th>
<th>Minor</th>
</tr>
</thead>
<tbody>
<tr>
<td>Anglo-German system</td>
<td>C</td>
<td>D</td>
<td>E</td>
<td>F</td>
<td>G</td>
<td>A</td>
<td>B</td>
<td>M</td>
<td>m</td>
</tr>
</tbody>
</table>

On the right of the two circles, two columns each containing eight boxes are visible. The first column shows the sequence of tones.

Thus, the first box at the top of the column shows the dominant tone of the sound modules at the beginning of the group. The next box shows the dominant tone in the middle of the first bar. The third box shows the tone of the beginning of bar 2.

![Tone of the piece at the beginning of the first bar](image)

**Two columns located on the right of the circles show the sequencing of tones.**
The tone sequence is therefore created every half bar, and stays visible for each group in the first column of the Kepler module.

The second column allows the transposition of the tone to a higher octave. By clicking in one of the boxes, it lights up in red indicating that the transposition has is active.

Selection of the tones is done by using the concentric circles. By clicking on one of the spheres in the circle, select a tone corresponding to that sphere from one of the boxes in the column on the right.

In this column, you should see a red border and a yellow border surrounding a box. A red border surrounding a box means that you can change the tone. A yellow border surrounds the box corresponding to the bar or half bar where the cursor is on the sequencer.

The Kepler module allows you to create modulations that will enrich your compositions.

Kepler can be applied to most instruments in Storm, (aside from drum machines, which are not melodic, EZ-Track, Scratch and the ReWire instruments). If you are using H3Opus, a slight manipulation may be necessary. Kepler needs to know the tone of the samples used in order to be able to transpose them, see the chapter Using samples to learn how to define the tone of a sample.

In any case, you can deactivate Kepler’s influence on the synthesizers. This can be done for each independent synthesizer module. You will find the Kepler Connection function in the contextual menu of each synthesizer, accessible with a right click (PC) or Control + click (Mac) on the synthesizer.
STATIC MODE COMPOSITION

What is static mode composition?

Static mode (also called “step by step” mode) allows you to record a series of manipulations which would prove difficult in real-time. For example, a quick succession of pattern changes, instantaneous variations to the volume, a radical change to the cut off... With static mode, you can program all of these movements directly from the sequencer in the stop position. Whether at the beginning or in the middle of a composition (it is of course possible to alternate between real-time recording and static mode during the progression of your song).

How to record in static mode?

• The first step is to select the static recording mode. You can do this either by selecting the menu option Studio > Record in Static mode, or by clicking on the grid of the sequencer with the right mouse button (Control + click for Mac), and selecting Record in Static mode.

The Record in Static Mode dialog then appears. A red flashing label and STOP button also appear on the extremity of the transport bar.

The Record in Static Mode dialog.

Note

The button on the transport bar will be deactivated during the static mode session.

• Once this is done, select the area on the sequencer corresponding to the instrument and the bars that you wish to edit. A red outline will surround this zone.

A red outline will surround the selected bars.
• You can now calmly program the changes to the pattern or parameter corresponding to the instrument selected on the sequencer (or a volume change or an effects parameter if it is an effect track). A red flash coloring this section indicates that the recording has taken effect. This parameter change will last for the duration of the selection.

• Next, select another section of the sequencer, and enter another parameter value or another pattern number, in the same manner as above. It is of course possible to listen in real-time to the changes you make!

• Once the static mode session is finished, click on Studio > End Static recording or close the text box Static record mode which is found to the right of the composition window to return to normal mode.
Using samples in WAV, AIFF or MP3 formats in your songs. The samples can be used, adapted, and modified in diverse manners with the modules H3Oplus, EZtrack and Scratch. This chapter deals with using samples in a general manner in Storm: importing, exporting, settings.

Using samples in a song

The sample library is the place where the sound samples are stored in the program. It contains:

- all of the samples supplied with the software
- what you yourself have imported to the studio
- what you have recorded in the studio with the recorder

The sample library can be accessed via the sample bank tab of the Explorer. If you are using the Hall, you will notice that the sample library is in the Navigation tab of the Hall.

The sample bank tab.

Including a sample in your song.

Among the accessible folders in the sample library, one of them is called Current song (this folder will take the name of your song if it has already been saved). This library contains a list of samples being used in your song.

Sample banks

The Installed Sample Kits folder contains several folders of samples classed by style and by instrument which are part of the Storm installation. To use these samples, simply open one of the folders (by double-clicking), select one of the samples, and drag-and-drop it onto one of the sample modules of your studio (H3Oplus grid, Scratch table, EZtrack editing zone).
Samples outside of Storm

In the same manner you can use a WAV, AIFF, or MP3 format file on your hard drive. For this, you just need to find the file with the Windows Explorer on PC or the Finder on Mac, and to copy it by drag-and-drop on one of the sample modules of your studio. Once it has been dropped on the module, a reference to the sample will appear in the Current song folder. This gives you quick access to external samples used in your song, and to modify their properties or delete them from the song.

Equally, you can do it in two steps: import the sample with the menu option Studio > Import a sample…. The sample is then referenced in the Current song folder. You can now select it in this folder and drag-and-drop onto one of the sample modules in your studio.

Saving the samples used in a Storm song.

When a song is saved, the program also saves all of the samples that have been used in the same file. You can find more information on this subject in the chapter Loading-Saving.

Exporting samples.

Proceed like the exportation of recorded sequences, described in the chapter Audio export.

Listening to or deleting a sample

It is possible to preview a sample before using it in an instrument like H3Oplus or Scratch. To do this, right click (Control + click for Mac) on the sample and select the Listen option in the menu, or click on the icon 🎧. You can interrupt the playback by right clicking on the sample for a second time and selecting the option Stop.

To delete a sample from the library:

- Open the sample library
- Select the sample that you wish to delete by clicking with the right mouse button (Ctrl + click for Macintosh)
- Next click on Delete.
The sample properties window

This pop-up window displays available information on a sample.

How to open it?

Just apply a right click on the sample and select Properties in the contextual menu.

What does it consist of?

• **Name**: the sample name
• **Listen**: click to have a preview of the sample
• **Sample rate**: The recording frequency in Hertz (for example, 44100 Hz)
• **Resolution**: the internal precision of the recording (i.e. 16 bits)
• **Channels**: the number of audio channels (1 Mono, 2 Stereo)
• **Tempo**: the tempo of the sample
• **Steps**: size of the sample in semi-quavers, or steps (16 semi-quavers represent one bar of 4 beats)
• **Key**: the key of the sample (click on the arrow to choose the note defining the sample key)
• **Deactivate Time Stretching**: if the option is selected, the sample will be played with its original tempo in H3O+ and will not be adjusted to match the studio tempo
• **Deactivate Time Stretching**: if the option is selected, the sample will be played with its original tempo in H3O+ and will not be adjusted to match the studio tempo
• **Fine tune**: fine tuning of the sample
• **Gain**: Sets the volume level of the sample
What is a .stm song?

In Storm, the word song has a particular meaning. It represents a series of manipulations.

When you work in Storm, changing a pattern, moving a controller or modifying the position of a slider are the actions which will bring about audible changes.

However, it is not possible to write a score that would take into account all of these modifications. Nevertheless, they can be stored in a .stm file. This file represents the score.

This .stm file is the saved configuration of the studio and the series of operations performed in that studio.

The sequencer at the top of the screen gives a representation of the .stm file and gives, as we have seen, several editing options.

What is the point in saving all of the manipulations and not just the sound?

The goal is to later reopen a song, to rework it or to extract a motif for another composition.

It also allows us to stock much smaller files than classic audio files (WAV, AIFF or MP3).

Does a song simply keep a trace of operations performed?

As we will see at the end of this chapter, not only does Storm create a synthesis of sound, it also offers the opportunity to work on existing samples. These samples are part of the software database but they can also be imported into the software using the sample library. When saved, the .stm file also contains samples present in the song.

To summarize, a Storm file saves:

the studio configuration + the manipulations made during the song + the samples used in the song.

Saving a song

When the composition is finished, you may want to give it a name and store it on the hard drive, on a diskette or on another suitable device. To do this:

- select the menu option File > Save as...
- Storm will request different information about your song (Title, Style, Author...). All of this information is optional, but could be useful to other Storm users if you send them your song.
The song information window.

• next click on OK; in the following window select where and under which name you want to save and click Save.

The song is now saved in Storm format (.stm file extension).

To save this song under a different name, select the option File > Save as..., confirm the name and click on Save.

You can directly access the save by clicking on the icon.

If your song uses samples (with the modules H3Oplus, EZtrack et Scratch), Storm will offer several options upon the first save of your song:

When saving, select your options concerning the samples in the song

• Include the samples in the Storm format
  • If you choose not to include your samples in the Storm format, the saved file will be much smaller, as it will only memorize the location of the audio samples used on your hard drive. When you reload the song, Storm will expect to find the samples at the same location. If you move the samples in the mean time, Storm will try to help you find them so as to reconstitute the entire song.
  • If you choose to include the samples in the Storm format, the audio files used in your song will be fully saved in the STM file, and you will have no trouble opening the song even if the samples have been moved or deleted in the mean time. In this case, the STM file will be much bigger. This type of saving is especially useful when you have finished the song and want to save it definitively, send it to other users or load it onto another computer.
• **Compress the samples**  
  In the case where you include the samples, if you choose to **compress the samples** in the Storm format, the audio files archived in the `.stm` format will be automatically compressed. This allows us to reduce the size of the STM file by around 10, but of course the quality of the samples will be slightly lowered.

### Loading a song

- In the menu bar, select **File > Open**. Browse your hard drive and indicate where your compositions are stocked.
- Next click on the name of the song that you wish to load.
- And click on **Open**.

You can go directly to the **File > Open** menu by clicking on the ![icon](image.png) icon.

If Storm has not been launched, it is also possible to load a song by double-clicking on the `.stm` file on your computer or even directly on a Web site.

When loading your song it is possible that Storm will return the following error message:

![Sample cannot be found](image.png)

This means that the song loaded had not included the samples in the STM file (see previous paragraph), and that some of the samples used cannot be found. These samples have probably been moved, renamed, or deleted from the hard drive since you last saved.

If you know where to find the file or the new name, you can indicate the location to Storm by clicking on each sample and on the **Select the file in...** option.

- If the samples have just been moved and you know their new location, you can indicate the new folder to Storm by clicking on the **Search for all of the files in...** option. Storm will look for the samples of the same name in the folder and subfolders.
- Finally, if you don't know where to find the missing files, you can choose the option **Ignore the problem**. In this case, the song will surely be incomplete as it will be missing samples, but you can still read it, and save it again without loosing the references of the missing samples that you can look for at a later stage.
Saving a song in the Storm (.stm) format allows us to later load a song and continue to work on it in the studio. This format cannot be read by other software. On the other hand it is possible to export a complete song, or an extract from this song in the WAV or AIFF audio standards: these formats can be read by most digital-audio applications, notably by multimedia players and by programs for burning audio CD's on both PC and Macintosh.

Storm offers 2 main choices for the audio export format:

- Use of the recorder, which is useful for short extracts and separate instruments and the audio export of the full song. The samples recorded can be directly reused on the sample modules in Storm.
- The audio export of the full song.

### Using the recorder

Click on the icon in the icon bar situated on the top of the screen or go to View > Recorder. The recorder will open.

- On the two controllers select the starting point and ending for the recording.
- Select the outputs that you wish to record. You can then record as many samples as you want at the same time.

The first tracks correspond to the instruments installed in the rack without their respective effect sends. This signifies that you are recording these modules without effects. The last track corresponds to the master record, which is to say all of the modules (except those muted on the mixing table) including their volume control and the effect returns.

- Click on the Record button, the recording will automatically begin.

After recording, the tapes corresponding to the tracks recorded on the recorder will appear in the sample library in Current song folder (this folder will take the name of the song if that song has already been saved).
After recording tapes represent recorded sequences.

Using and exporting saved sequences

The recorded sequences can be used in different manners: within the program or outside.

Using sequences recorded internally

The recorded sequences will appear in the form of tapes in the Current song folder in the sample library.

The tapes can be moved by drag and drop to instruments using samples (for example the sample sequencer H3O+ or the scratch module).

Exportation of recorded sequences

To export for use in an external program (for example audio treatment or CD burning):

- Select the tape that you wish to export by clicking on it with the right mouse button (Ctrl + click for Macintosh)
- Click Export
- Choose the exportation format
- A browser will appear to ask you where you wish to export the sample to. Choose a folder and enter the name you wish to use. When you click on OK, the sample will be saved to your hard drive at the selected location.
To export a finished song, click on the menu **File > Audio Export**.

- Choose the exportation format (Wave 16/24 bits or Aiff 16/24 bits)
- A browser will appear and prompt you to specify a destination for the file.
- Choose a location and name the file you wish to create.
- The exportation will start and a progression bar will indicate the exportation speed and the time remaining.

*Click on export and choose the format for exportation.*
MIDI control of potentiometers

If you have a MIDI keyboard or controller surface, it is possible to associate these physical controllers to Storm potentiometers.

The method for this is simple:

• The first step is to make sure the MIDI device is connected to your computer.
• Also check that you have correctly selected a MIDI input device in the Storm preferences (Settings > Audio & MIDI menu).
• On the Storm sequencer, select the instrument track which is to receive MIDI control. For more information on assigning a MIDI channel to an instrument or forcing MIDI reception to it, go to the chapter on the Sequencer.

Once these verifications have been made:

• Place the mouse on the Storm potentiometer that you wish to physically control.
• Hold down the Ctrl key while clicking on the potentiometer.
• The selected potentiometer is highlighted and a window will open displaying the state of the MIDI control:
  • Check box On: check this box if you wish to activate MIDI control for the potentiometer.
  • Control number indicator: select the MIDI control number that you wish to assign to this potentiometer (from 0 to 119).
  • Learn button: this is another manner to assign MIDI parameters to a potentiometer. Click on Learn, Storm will now wait until you have manipulated the physical controller that you wish to assign to the potentiometer selected in Storm. The MIDI control number detected will be indicated upon reception of MIDI messages of the “Control Change” type.

1. The mouse is placed on the controller you wish to manipulate physically.
2. A MIDI control window opens under the selected controller.
3. Assign the MIDI parameters or use the Assign function.
As long as you keep this control window open, you can set as many potentiometers as you like, one after the other. To do this, click on a potentiometer, configure it with the Control number for this potentiometer (or use the Learn function), select another and begin the same operation. When you are finished, close the MIDI control window.

Throughout this operation, the selected potentiometers positions are blocked: you can therefore assign MIDI controllers without worrying about losing your potentiometer settings.

### Piloting instruments through MIDI

It is possible to play Storm instruments with a physical MIDI keyboard. Just select the channel number on the top of the track corresponding to this instrument in the Storm sequencer. The simplest method is to choose Omni (reception on all channels), and to select the track by clicking on it. The sound of the selected instrument will immediately be available on the keyboard (attention, make sure that the MIDI input device is correctly selected in the Audio and MIDI preferences of Storm).

You can record what you are playing as a MIDI sequence. For this, select a group of bars on the track corresponding to the instrument chosen in the Storm sequencer. Right click (control + click for Macintosh) on the selection and choose the option Create a MIDI sequence in the contextual menu. When the MIDI sequence is created, place the playback head in front of the sequence and click on the record button on the Control bar. Now click on Play and start to play on the keyboard: everything that you play will be recorded in the MIDI sequence.

For the drum machines, each instrument of the drum machine will have its own space on the MIDI keyboard (for more information see introduction to drum machines chapter).

### MIDI Synchronization

You can synchronize Storm with hardware or software through the MIDI protocol.

To configure the synchronization, click on the Settings > MIDI Sync menu.

Then a window opens asking you to indicate whether Storm should be the master of the second device, i.e., the user controls both devices from Storm - or the slave - and Storm is directed by the other device.

Also, two MIDI devices can have a different latency when started. This will bring about an audible delay between the two devices. To allow the synchronization despite this, the Latency setting will compensate for this delay so as to obtain a perfect synchronization.

![Synchronization window](image-url)
IMPORTING MIDI FILES

Storm 3.0 can import MIDI files (extension “.mid”). The very common MIDI file format is a standard format for stocking musical partitions. A MIDI file generally defines a group of tracks (MIDI sequences) which must be played simultaneously by different instruments. A full song including rhythms, basses, accompaniments and melodies can be stocked inside a single and very compact MIDI file. A MIDI file never has any audio information (no audio recordings, in other words no samples). It simply defines the notes which must be played, the type of instrument which is to interpret them (trumpet, piano, synth, etc.), as well as the different parameters for interpretation: volume, modulations, etc. Thankfully, Storm 3.0 also offers the GMSynth module, which is a generalist instrument capable of producing all of the sounds defined by the general MIDI norm with very high audio quality. All MIDI files are done justice with Storm 3.0.

Opening a MIDI file

You can import a MIDI file at any moment:

- either after having created a new empty studio: in this case after importation, a certain number of GM-Synth instruments will be created on your rack, this, depending on the number of instruments contained in the MIDI file. You can then add your own instruments and effects to complete the song or do a remix.
- or if you are already working on a song with several instruments and effects on the rack. In this case, the importation of the MIDI file will have as effect the addition of a certain number of GMSynth instances in the rack without affecting the other instruments which are already present. The work already done on the current song will not be lost, but certain general settings may be changed by the importation: new tempo changes any appear in the sequencer, and the automation of the master section of the mixing table can also be changed.

In the two cases, to import a MIDI file, go to the Storm File menu and choose Import a MIDI file. In the file selection dialog that appears, choose the MIDI file to be imported.

Working on the imported song

Once the MIDI file has been imported, you can see that all of the GMSynth instances created are in the “MIDI sequence” mode, which means that the patterns are inactive. On each sequencer track corresponding to a GM-Synth, a MIDI sequence has been inserted and replaces the patterns. You can edit the MIDI sequences at your convenience with the piano roll to modify the imported song. You can also add effects, or instruments, and program them using patterns or creating new MIDI sequences on the global Storm sequencer.

Each instance of GMSynth receives a MIDI sequence replacing the patterns
The Piano Roll allows advanced editing of MIDI sequences and melodic patterns. It can also edit the continuous controls recorded in the song (like the volume and pan for example).

The Piano Roll can be accessed through the View > Piano Roll menu or by clicking on the corresponding icon on the toolbar: 🎹. It can also be opened with a double click on a pattern visualization or a MIDI sequence in the Sequencer, or through a right click on an instrument to select the pattern, the MIDI sequence, or continuous control to edit.

Depending on the function edited (melodic pattern, rhythmic pattern, MIDI sequence, continuous control), the Piano Roll presents up to three different editing zones:

- The melodic editing zone (in the case of a melodic pattern or MIDI sequence). This zone is also active for the edition of a rhythmic pattern, but the presentation differs slightly:

  ![The melodic editing zone.](image)

- The velocity editing zone, which is generally active simultaneously with the melodic editing. This zone sets the velocity for each note of a melodic or rhythmic grid:

  ![Velocity editing zone](image)

- The continuous control editing: this zone is available either in the case of the direct editing of a continuous control (volume, panoramic, cut-off, etc.) which is done for the entire duration of the song, or in the case of the edition of a rhythmic pattern (Meteor, Hork, etc.) as in this case the Pitch and Decay controls are part of the edited pattern:
The editing zone for a continuous control

Piano Roll toolbar

The Piano Roll toolbar contains a certain number of tools which will be useful for the editing of your patterns, sequences or continuous controls:

- Drawing tool: this tool is used to insert notes, and modify their length and height.
- Eraser tool: this tool removes notes.
- Selection tool: this tool draws a rectangle to select a group of notes.

These three tools function in the same manner in the editing of a continuous controller: the drawing tool allows you to draw a curve that the edited continuous controller will follow, the eraser tool allows us to remove a part of this curve, and the selection tool allows us to select a portion of a curve (to copy it to another location for example).

The fourth button on the toolbar is to show or hide the velocity edition zone (in the case of the edition of a melodic or rhythmic sequence):

The following choice called Resolution is to select the resolution wanted for the edit. The resolution defines the detail of the editing, which is to say the division of the bar into sub-divisions called steps. This parameter cannot be modified when dealing with the edition of a simple pattern. The patterns in Storm are generally 16 steps per bar. On the other hand, this parameter can be modified for a MIDI sequence, which allows the use of an editing detail superior to the semiquaver.

The “previous” and “next” buttons allow us to easily return to a pattern or sequence already edited. They also give access to the pattern or sequence history through a click on the button.

The two following buttons contain the name of the instrument being edited, and the name of the pattern/MIDI sequence/continuous controller being edited. We can easily select a new element to edit in another instrument with the first button, or another element in the same instrument by clicking on the second button.
Melodic editing of a pattern or MIDI sequence

The melodic editing zone of the Piano Roll lets us visualize and modify the sequence of notes recorded in a melodic pattern or MIDI sequence. The vertical scale represents the height of the notes, with the keyboard on the left giving the pitch reference. The horizontal scale represents the time, in bars and sub-divisions, depending on the graduations displayed in the upper part.

The range of the editing zone (number of available octaves) depends directly on the type of pattern or sequence edited. For a bass pattern (Arsenic, Bass52), the range will typically be 3 octaves, while for a MIDI sequence or an Orpheus pattern, the range will be of 128 notes or 12 octaves and one half. The number of bars edited depends on the pattern (Arsenic: 1 bar, Orpheus: from 1 to 8 bars), or the length of the MIDI sequence edited.

The melodic editing zone responds differently for mouse actions depending on the tool selected (in the toolbar):

**Drawing tool**

With the drawing tool, a click on the melodic grid adds a note. This note can then be dragged with the mouse button held down and moving the cursor to the right. Thus, with a single click we can add a note and define the length. Equally, if you move the mouse cursor up or down (all while moving towards the right), you will create a new note each time you change graduation along the vertical scale of the tone height.

In this mode, you can also modify the length of an existing note. For this, move the mouse cursor to the extreme right of a note. The cursor transforms into a double-ended arrow pointing left and right. If you now click and move the mouse to the right or left (while holding the mouse button down), you will change the duration for the note. Attention, in certain instrumental patterns, those on Arsenic for example, the note duration cannot be modified.

It is also possible in this mode to change the height of a note. For this, move the mouse cursor to a note (but not to the extreme right of the note which changes the length), the cursor takes the form of a double-ended arrow pointing up and down. If you click at this time and move the mouse up or down (while holding the mouse button down) you will change the height of the note.

**Eraser tool**

With the eraser tool, you can remove a note by clicking on it. You can also remove several notes but holding down the mouse button and using the mouse like an eraser.

**Selection tool**

The selection tool is used to group the notes together, and apply changes to this group of notes in order to transpose them, change their duration, or move them. To select a group of notes, click on the selection tool in the toolbar, then click on the grid and drag the mouse to make your selection (keeping the mouse button held down). All of the notes within the rectangle will be selected. You can now add or remove notes in the selection by clicking on it while holding the Shift key down. You can cancel the selection by clicking on the grid.
When the notes have been selected in this manner, you can click on the extreme right of a note (mouse cursor showing a double-ended arrow left-right) and move the mouse while keeping the button held to simultaneously change the length of the selected notes. You can also click on one of the selected notes and move all of the selection to the melodic grid, to transpose or move it to another time (with the mouse button still held). By returning to the eraser tool, you can delete the selection with a single click on one of the participating notes.

The selection can equally be duplicated, to the same melodic sequence or another. For this, select Copy in the Edit menu. Next click on the area of the melodic grid that you want to copy your selection, and select Paste in the Edit menu.

**Editing the velocity**

The velocity of a note represents its intensity or force (or audio volume). The term comes from piano playing, where the faster the finger hits the key, the heavier the impact of the hammer on the string, the louder and brighter the sound. The velocity is generally detected by MIDI keyboards, and has become an essential form of expression in playing a synthesizer keyboard. As a consequence, the editing of MIDI sequences or melodic patterns in Storm brings access to this setting for every recorded note.

The visualization and editing zone of the velocity can be found under the melodic editing zone. It can be hidden or activated by clicking on the velocity button in the Piano Roll toolbar. Each note on the melodic editing grid corresponds to a bar in the velocity editing zone. This bar by its height expresses the velocity associated to each note. The higher the bar, the louder the note. Each velocity bar can be edited by placing the mouse cursor on the superior part, clicking and holding the mouse button while moving up or down.

**Editing a continuous controller**

All potentiometers and sliders in Storm which are used to set a value (volume, filter frequency, etc.) are here called continuous controllers. Their variations can be recorded continually throughout the song, simply by setting the setting the sequencer to record mode and manipulating the controllers in real time. The static recording mode also allows you to set a fixed value for a continuous controller for a group of bars.

The Piano Roll allows the visualization and graphical editing continuous controller variation throughout the song. It can easily help program a fade-out for example at the end of the song, to make the music “disappear” into silence: just progressively diminish the volume setting over a few bars until you reach zero volume.

To edit a continuous controller, you can:

- either open Piano Roll (with the View > Piano Roll menu or with the icon in the global Storm toolbar), and click on the button indicating the choice of module being edited (on the Piano Roll toolbar this time). A menu will appear, allowing you to choose the module to be edited, the pattern, the MIDI sequence, or controller to be edited. Select one of the controllers offered on the module that you wish to edit.

- or by a right click on the instrument or effect to be edited, follow the Edit option in the menu that appears and choose the appropriate controller.
Choice of element to edit using the buttons on the Piano roll toolbar

- or by double click, directly on the controller (potentiometer or slider) that you wish to edit. Attention, with a double click you run the risk of modifying the value of controller that you have chosen, this is why the two previous options are preferable.

Choice of element to edit using a right click on the instrument or effect (Apple + click for Mac)
The continuous controller editing zone responds differently to mouse action depending on the tool selected (in the toolbar):

**Drawing tool**

The evolution of the value for the continuous controller is represented by a blue curve. The yellow points mark the points where a value is effectively recorded. Everywhere else, no signal is recorded, and the curve is flat (same value for a whole period) until another eventual yellow point. Once the drawing tool is selected, we can click on the grid to add a value, and draw a curve by keeping the mouse button held down. By positioning the mouse on a defined value (yellow point) of the curve, the cursor transforms into a double-ended up-down arrow: by clicking, we can modify the value of this particular point of the curve.

By clicking anywhere on the grid with the Shift key held down, we create a rectilinear curve between the last value edited with the mouse and the value corresponding to the new position of the mouse.

**Eraser tool**

With the eraser tool, you can cancel the recording of value changes for the continuous controller you are editing. Position yourself at the start of the zone that you want to erase, and hold down the button while moving the mouse. The removal of the data can be seen with the removal of the yellow points. Where you have removed recorded values, the blue curve is now horizontal, fixed at the closest previous value that you have not deleted.

**Selection tool**

Here, this tool defines a selection: click on the grid, and drag your selection holding the mouse button down. You can use the Copy, Cut and Paste options contained in the Storm Edit menu.

*Attention:* The potentiometers available on drum machines are not like the others: their variations are not recorded throughout the song, but are part of the data in a rhythmic pattern. Editing these controllers is done through editing the rhythmic pattern as explained in the following paragraph.
When editing a pattern on a drum machine (Meteor, Hork, Psion, Puma, Tsunami), you can at the same time edit the rhythmic sequence (trigger of percussive sounds over time), and the simultaneous variation of each of the instrument controllers: “Pitch” and “Decay” for a sampled drum machine, or a group of synthesis parameters for Tsunami. The editing space for the continuous controller is very short, as it a single bar for each pattern. A selection box allows you to choose a controller to edit among those available on the current instrument.

*Editing a rhythmic pattern: rhythmic grid, velocity, and continuous controllers*
**What is ReWire?**

ReWire™ is a software interface developed by Propellerhead Software™ to transfer MIDI and audio data between different applications. This protocol allows to connect several ReWire compatible applications, and to get the sound of all the applications in just one of them, by synchronizing their sequencers. The application that mixes the sound of these interconnected applications is called a ReWire mixer, the others are ReWire instruments.

Storm can be used either as a ReWire instrument or mixer. Thus it is possible to:

- use Storm as a ReWire instrument in a ReWire mixer such as Steinberg Cubase™ or Ableton Live™.
- use Storm as a ReWire mixer and to mix the sound of ReWire instruments such as Reason™ or Rebirth™ from Propellerhead Software.

**Using Storm as a ReWire mixer**

To use Storm as a ReWire mixer, you must launch Storm before any other ReWire application. The first application launched is the mixer.

To open a ReWire instrument, go to the ReWire Instruments tab of the explorer and drag the instrument of your choice to the Rack. If this tab does not appear, make sure that the option Settings > General/Activate ReWire mixer on launch of Storm option is active, and that you have launched Storm before any other ReWire compatible application.
The ReWire instrument will thus behave like the Storm internal instruments: it will have its place on the mixing table, and you can direct it to the effects in Storm. On the rack instrument, you can determine which audio channels are used.

**Note**

Attention, certain ReWire instruments are not launched automatically. It can be therefore necessary to launch the corresponding application after having dragged the instrument to the Storm rack.

Once the application has been launched, the two synthesizers are synchronized, and the sound of the two applications is mixed in the ReWire mixing table in Storm. You can indifferently play, stop, change the tempo, etc. in one or the other.

It is possible to open the same ReWire instrument several times, they are connected to the same application. You can thus differently mix several channels of this application.

When exporting audio in Storm with the **File > Audio Export** menu, the ReWire instruments are included in the audio file produced.

To remove a ReWire instrument, do so as you would any of Storm’s other instruments: right click on the instrument in the Rack (Control + click for Mac), and select **Remove Module**.

Finally, before quitting Storm, you need to quit all ReWire instruments.

### Using Storm as a ReWire instrument

To use Storm as a ReWire instrument, you just need to select Storm in the instruments proposed by your sequencer (look at the documentation of your sequencer). Storm is thus generally automatically launched and connected via ReWire; if this is not the case (particularly in Cubase), launch Storm manually, *after* having launched your sequencer.

The sequencers in Storm and your mixer application are then synchronized, and the sound from Storm is mixed by the mixer application.

Storm can export up to 64 audio tracks to the ReWire mixer; you can use the **Settings > Audio Connections** dialog box to choose the output channels for the different Storm instruments.

**Remark:** The audio preferences are inactive and remain so as long as Storm is used with ReWire.

Storm is also capable of receiving MIDI events coming from your sequencer. These events will be routed depending on the settings selected in the Storm **Sequencer**. Note that not all sequencers are capable of sending MIDI through ReWire.
THE HALL

The Hall in Storm 3.0 allows you to join the Storm users “community” by using your Internet connection.

It is in fact a set of functions grouped together in a window independent of the studio. This Hall will help you to exchange samples and files for your compositions, chat, be informed of all of the latest news concerning Storm, or even to share hints and tips.

Launch

To launch the hall, click on the icon in the Storm toolbar. The main Hall window will open and you can connect by clicking on the Connect button. You will be asked for a login name and password, and you will use this to identify yourself with the server for your future connections. To make your login to the server automatic, have a look at the hall configuration section.

News and tips

Once you are connected, a click on the News tab will bring you to the Arturia news section. In this zone you will find information concerning Storm, the users community, new modules... This zone acts like a web page, and the links are clickable. In the same manner the Tips tab gives you access to a list of tips available on the use of Storm. To get to a tip, simply click on the one you want.

The button is the welcome page, it brings you back to the available tips list. The button is “Previous” and will bring you back to the last page consulted.

![Storm Hall Interface](image)

WELCOME TO THE STORM HALL

- NEWS Read the weekly news
- NAVIGATION Browse and share your samples and compositions
- SEARCH Search for shared samples and Storm files
- CHAT Chat with other Storm users and share resources
- TRANSFERS Control your file transfers
- TIPS Learn new composition tips and tricks

You are currently not connected. Click on CONNECT to enter the Hall.
Sharing and searching for files

On your computer, you store samples, .stm files in folders. You can decide if you wish to let other users use them for their compositions. To configure the sharing of your folders, go to the Storm configuration chapter.

Most hall users will also have shared samples and .stm files. A large quantity of resources is thus available thanks to the Hall, and you will be able to benefit from this with a resources “search engine”.

To search for a resource, click on the Search tab, and type a complete word in the find files field. You can choose if your search is to be processed concerning samples, Storm files or all criteria. You can also perform a more precise search by choosing Advanced.... With this search mode, you can search for files by file format, title, the tempo and maybe find the files you need in other users resources.

Once you have filled out your search criteria, click on Search. The Hall will then connect you to the Arturia server which will sift through the other users shared resources. The results sent by the server will progressively appear in the list of files. If you are searching for samples, you can listen to a preview by clicking on the button or by selecting the file, right clicking it and selecting Preview. The preview functions by the quick download of a compressed version of the sample that interests you. This lets you listen to several samples before choosing the ones that you want to download. As a result of the compression, the sound quality of the preview is a little lower than the sample itself. The preview is not always possible depending on whether or not there is a compressed version of the sample on the computer of the user sharing the resource or not.

You can equally, with the button or thanks to a right click (Ctrl + click for Mac) display information relative to the selected file. If you are interested by one or several files, you can select the files concerned and click on Download or use a right click to Download the selection. Download will let you to download the selected file to the folders managed by the Hall Navigator. With the sub-menu you can choose the folder on your hard drive to which you wish to download the file.
Tips

By drag-and-drop, you can directly drop a sample in the search list to your studio on modules such as Scratch, H3O+ or EZtrack.

For the downloading of a file/files selected, the server will help you to connect to the computer from which the file is being shared. You can monitor the status of your download with the Transfers tab.

Transfers tab

This window represents in its upper section the state of the file downloads from the computers with whom you are connected to exchange files. For every file currently being downloaded, you can stop the download by clicking on the button. This can equally be done by right clicking on the file concerned. In this Transfers window, by using the button, you can make the list easier to read by removing the stopped or completed downloads.

Once the download is finished, the files are available on your computer. The choice of download folder can be made in the Hall configuration options.

Warning

The files you are sharing will be visible and available to download for Hall users who access the files and information present in the folders you will share. Please ensure that these folders contain no elements that you do not wish to share with other people.
The Navigator

Like the Windows explorer which allows you to navigate in the file system of your computer, the Hall navigator lets you browse the resources elements available in Storm 3.0. To use this “Navigator”, simply click on the Navigation tab. You will then see a two part window.

### Navigation tab

The left side shows a list of resources regrouping the resources available on your computer. If the Storm samples CD-ROM is present in your drive, you will see the CD sample banks appear in a sample banks folder on the CD. The third folder lets you access the samples used in the Storm song that is currently open or in the song you are currently composing. Next you have access to all of your shared folders.

The button lets you add a folder on your computer to your navigator shared folders. The button lets you stop sharing a shared folder.

In the right part of the navigator, you can see AIFF format samples represented by icons, WAV format samples represented by icons, MP3 format samples represented by and finally icons for STM format samples. You can listen to a sample by clicking on the button in the toolbar, or right clicking (Ctrl + click for Mac) the sample and selecting Listen. You can get information concerning the sample by clicking on or with a right click.
The toolbar can also help you to delete a sample after having selected it with the button, the button lets you refresh the list displayed and the button is to go back to the parent folder. You can also “post” a sample in the chat room (see Chat), so that this sample is available in the discussion window and that the users in this room can download it. The button or a right click (or Ctrl + click) on Post on room, and choosing the room for it to be posted in lets you do this. Finally, it is possible to send a sample to a user with the button.

The Hall Chat

This is the main function of the Hall, the chat will not only help you chat with a classic discussion system, but it is also associated to a system for resource sharing described in section 2. To launch a chat, click on the Chat tab and you have access to the main chat window. The left side of the window represents the HotList, and here you can add the users that you have had discussions with by using the button. You can get information on a user in your friends list with the button. You can propose a private dialog with a user with the button, send the user a file (button). You can also access these functions by right clicking (or Ctrl + click for Mac) on the user in the HotList.
The right side of the main window lets you see all of the discussion rooms created by users. You can update this list with the button. To create a discussion room, click on the button and enter in the following window the name and theme for the room. In the list of rooms, the rooms represented by the icon are the locked rooms, and the rooms with the icon represent the rooms which can be joined.

To join a chat room, select the room of your choice and click on . As many new tabs as rooms joined will appear at the bottom of the Chat window. With these tabs, you can navigate from room to room and return to the room list (HotList tab).

In a chat room, the chat window is composed of several distinct sections:

- The left section shows the list of users connected to the room, and you can get information for each user of this list (button), you can add the user to the hot list.
- The upper section shows the name of the current room. The button lets you lock or unlock entry for other users for the room. If the button shows an open lock, other users can join the room, if the lock is closed, then you have locked access to the room for other users. The button lets you to quit the current room.
- The central section shows the current discussion.
- Underneath is the input zone for your text (hit the enter key to send your text).
- The lower section of the chat window shows a list of resources shared by the users that you can download.

Files shared during a discussion
The 5 configuration options for software and hardware in Storm can be found in the Settings menu. Here you will find the audio configurations, MIDI, general, and the Hall settings. The configuration settings can be found in the menu bar. The three first options are grouped in a system of tabs, which allows the fast navigation in most of the program settings.

General options

This window contains the information concerning choice of language, the type of keyboard, sample compression and the studio startup options.

*Language:* The choice of language used in the menus and functions of the program.

*Save options:* configure Storm to include samples in the .stm files, so as to manage their size.
  - *Ask to include samples:* Storm will ask for confirmation of inclusion of samples every time you save a STM file.
  - *Include samples:* Samples will always be included and Storm will not ask for confirmation.
  - *Compress samples:* If this option is selected, the samples are compressed when included in an STM file.

*Studio options:*
  - *Show the “Where to Start?”* allows you to activate/deactivate the automatic launch of the Where to Start window when Storm is started.
  - *Auto start playing:* if this option is activated, the studio will automatically play after the Start button is clicked. In the contrary case, the sequencer will remain in the Stop position, and you will need to click on the Play button.
  - *Clear all patterns:* this option lets you create a new studio without the default patterns, and this is for all instruments.
• **Activate ReWire mixer**: select this option to set up the activation of Storm as a Rewire mixer at each launch.
• **Default tempo**: here you can set the default tempo of the new studios created

---

### Audio and MIDI options

Here you will find the parameters concerning your audio configuration.

- **Audio out**: This is the choice of sound card to be used for the audio output of Storm, and of the associated driver (ASIO or DirectX). We recommend the use of the ASIO protocol if you own a compatible card: this will help obtain a weaker latency.
- **Audio in**: The choice available will depend on the output device selected. Storm will use the input selected as the source for recording, with the EZtrack module for example.
- **Latency**: sets the synthesis engine delay in relation to operations within the software. The latency time that you can get depends on your sound card and the power of your computer.
- **CPU load tolerance**: sets the maximum load tolerated by the CPU before the interruption of the synthesis engine.
- **ASIO config**: accesses the sound card control panel.

---

![Audio configuration](image.png)

**Audio and MIDI configurations**

- **MIDI output device**: This is the choice of MIDI drivers to which the Storm MIDI output will be sent (essentially in a case of MIDI Sync with Storm as master). Several MIDI devices can be checked.
- **MIDI input device**: This is the choice of MIDI interface connected as input. Several interfaces can be checked, which allows you, for example, to use several MIDI control keyboards simultaneously with Storm.
CPU error

When the CPU load is too heavy, Storm is interrupted and a dialog box will be opened. It proposes the setting of a tolerable maximum CPU load.

It should be noted that a CPU load around 80% will strongly slow your computers reactions! It is then recommended that you remove some of the “heavier” modules from your studio: Shadow, GMSynth, Vocoder or Reverb. When the load is too heavy, you have the choice to Continue or to Stop to allow you to remove modules from the rack.

Hall options

This tab is just for the Storm Hall and will help you to set your connection parameters, your download options, and your folders.

- **Login/Password**: indicate your login and password to identify yourself in the Hall.
- **Connection speed**: indicate your connection type so as to optimize the Hall depending on your bandwidth.
- **Max uploads**: indicate the number of downloads that users can perform simultaneously on your shared folders (select a reasonable number depending on your Internet connection).
- **Max search results**: indicate the maximum number of results displayed when searching for files.
- **Behind firewall**: indicate if you a behind a firewall. The Hall will adapt itself to this particular configuration.
- **Auto connect to server**: check this option if you want to automatically connect with your login when the Hall is launched.
- **Refuse private chat requests**: check this option if you want to automatically refuse all offers of private chats from other Hall users.
- **Shared folders**: list of all shared folders on your local hard drive, and accessibility for Hall users. Use the Add button to include a new folder in the list, and the Unshare button to remove this folder from the list.
- **Download directory**: lets you choose, among your shared folders, where you want to download your files to.
Audio connections

You can configure the routing of audio input and output for each Storm instrument towards those of your sound card. This function is especially interesting if you have an ASIO sound card with multiple outputs or when you are working in VST mode.

Click on the menu **Settings > Audio connections**. The window that opens will present you with:

- The graphical representation of the instruments present on the Storm rack, plus the representation of the **MASTER**, which is the main output from the mixing table.
- On either side of the **MASTER** and the different instruments we find scrolling lists. These are for connecting the different audio channels of the sound card as output or input of each instrument individually, and the **MASTER**.

Example of connections

Imagine that you have a sound card with 8 inputs and as many outputs. It is possible to send each module to a different output on your sound card. You could therefore apply audio treatment coming from your hardware mixing desk (equalization and effects for example) on each of Storms instruments separately.

To establish a connection between the output of an instrument and a sound card output, choose an audio channel available in one of the two scrolling lists for this instrument. The first list chooses the audio output for the left instrument track, and the second for the right track.

To select the audio channels to be directed to the audio input of the EZtrack module, choose them in the two scrolling lists on the left of EZtrack in the audio connections panel.

![The audio connections settings](image)

**MIDI Synchronization**

You will find the parameters concerning your MIDI configuration and MIDI synchronization (with an external drum machine or a sequencer for example). It can only be opened from the composition screen and not the studio builder.

For configuration of MIDI synchronization, see the **MIDI** chapter.
# KEYBOARD SHORTCUTS

<table>
<thead>
<tr>
<th>ACTION</th>
<th>WINDOWS</th>
<th>MACINTOSH</th>
</tr>
</thead>
<tbody>
<tr>
<td>Play/Stop (playback or recording)</td>
<td>Space bar</td>
<td></td>
</tr>
<tr>
<td>Recording mode ON/OFF</td>
<td>* (numerical keypad)</td>
<td></td>
</tr>
<tr>
<td>Delete a module</td>
<td>Del</td>
<td></td>
</tr>
<tr>
<td>Open a Studio</td>
<td>Ctrl + O</td>
<td>⌘ O</td>
</tr>
<tr>
<td>New Studio</td>
<td>Ctrl + N</td>
<td>⌘ N</td>
</tr>
<tr>
<td>Save a Studio</td>
<td>Ctrl + S</td>
<td>⌘ S</td>
</tr>
<tr>
<td>Save as...</td>
<td>Ctrl + Shift + S</td>
<td>⌘ S</td>
</tr>
<tr>
<td>Cut a pattern/a bar</td>
<td>Ctrl + X</td>
<td>⌘ X</td>
</tr>
<tr>
<td>Copy a pattern/a bar</td>
<td>Ctrl + C</td>
<td>⌘ C</td>
</tr>
<tr>
<td>Paste a pattern/a bar</td>
<td>Ctrl + V</td>
<td>⌘ V</td>
</tr>
<tr>
<td>Restore a pattern/ a bar</td>
<td>Ctrl + Z</td>
<td>⌘ Z</td>
</tr>
<tr>
<td>Mute ON/OFF bars selected on the sequencer</td>
<td>M</td>
<td></td>
</tr>
<tr>
<td>Select and activate a module</td>
<td>Numerical keypad arrows</td>
<td></td>
</tr>
<tr>
<td>Song information</td>
<td>Ctrl + I</td>
<td>⌘ I</td>
</tr>
<tr>
<td>Quit the Studio</td>
<td>Ctrl + Q</td>
<td>⌘ Q</td>
</tr>
</tbody>
</table>
SYNTHESIZER BASICS

What is a synthesizer?

A Synthesizer is a piece of electronic equipment capable of producing a sound. In this manner it represents a new type of musical instrument as it does not reproduce the sound but creates its own. In Storm, this category is represented by the following modules: Arsenic, Bass 52, Equinoxe, Orpheus, Shadow, GMSynth and the Tsunami drum machine. A synthesizer can also be characterized by acting upon multiple sound parameters, to modify the tone, the frequency or the resonance for example.

In Storm Music Studio, we also find sample modules, used to record, play or mix sound files, as well as drum machines, which will be used to trigger rhythmic sounds at regular intervals. All of the elements present in the synthesizer library will be called instruments or instrument modules even if they are not synthesizers in the strict sense of the term.

The pattern selector

On nearly all of the synthesizers, you will see a pad with numbers and letters. (The only ones without this are the scratch and EZtrack modules).

As you may have seen in regard to pattern selectors, patterns are pre-recorded. You can compose your song by using provided patterns.

Patterns are coded by a letter between A and D and two numbers between 1 and 4. For example B12. This means that 64 different patterns are available.

Initially all of the instruments will be set to the first pattern, A11. The control window under the selection keypad indicates the pattern number.

To change patterns, click on the other letters or numbers in the grid. The new key you have selected is going to blink until the end of the current bar. The change in pattern will take place at the end of that bar.

The keys selected blink until the end of the current bar.

You can modify existing patterns on all synthesizers. However, the technique to do this differs for each one and will be described later for each case. If you wish to return to the original pattern, click on the RESTORE button.
Click on the **RESTORE** button to go back to the original pattern.

If you wish to completely erase a pattern, click on the **CLEAR** button.

Click on the **CLEAR** button to erase the current pattern.
The Arsenic bass line has the same features as the vintage synthesizers from the 1970's. A square oscillator is modulated by a low pass resonant filter.

The instrument module interface can be divided up into two parts:

- The Piano Roll for the programming of a melodic loop.
- The potentiometers which allow you to work on the sound produced.

**The Piano Roll (or pattern composition grid)**

The Piano Roll, which is a note grid and a piano keyboard lets us create melodic loops.

As you can see, the grid is composed of 16 bars each representing one of the 16 beats of the bar. These bars are for the programming. The keyboard is a reduced piano which allows the visualization of the note programmed on the grid.

This system helps us to create melodic loops. To position a note, click on the grid. To delete it, click on the note with the right mouse button (Ctrl + click for Mac). To move it, click on the middle of the note and drag it up or down.

Two octaves are represented on the keyboard. To vertically move and see the notes that you have placed on the other octaves, slide the lift on the right of the screen up or down.

Elsewhere, on the left of the Piano Roll, you have a slider between 1 and 4 which can help you to transpose the song to another octave. Each step corresponds to an octave: by going from 2 to 3, all of the notes will be played on the next octave.

**The different editing modes**

The 3 different icons which give access to these modes are on the left of the Piano Roll: from top to bottom, you will find: edit the notes, edit the liaison between notes, and edit the velocity (or volume).
• **Editing the notes** represented by the icon is how to (as we have seen in the previous paragraph) place notes on the Piano Roll. To vertically and horizontally zoom on the notes, and to move within the pattern, use the scroll bar on the right of the Piano Roll.

• **Editing the slide between notes** represented by the icon is to link a note to another and create a legato effect (one single attack for the two notes). To create the link, click on the icon, click on the first note of the two to link, and without letting go of the button, drag to the second and release. A red line will appear between the two notes to confirm the liaison. These links modify the attack of the notes: the attack and delay applied will be on the two notes together and not individually.

• **Editing the volume** represented by the icon allows us to set the velocity of each note. When you are in this mode, all of the velocities are set to average. To modify the velocity, lower or raise the column above the desired note and thus change the volume.

**Editing on the piano roll**

It is also possible to edit Arsenic patterns and parameters with the **Piano roll**. This will allow you to more comfortably edit the different notes and controllers on Arsenic.

• To open the piano roll, right click (Control + click for Mac) on the instrument and select the menu **Edit > Pattern** and choose the pattern that you wish to edit from the list.

• To edit the pattern, use the “drawing” tool and click on the grid to display the notes corresponding to the instruments.

• To remove a note use the “eraser” tool and click on the note.

• It is also possible to change the volume for each note on the volume editor just under the piano roll. Raise or lower the column under the note.
The piano roll

A second section on the piano roll lets you graphically edit the curve of an Arsenic potentiometer.

- Perform a right click (⌘ + click for Mac) on the edge of the synthesizer and choose the setting that you wish to edit with the menu: Edit > Controller.
- Shape the curve with the drawing tool. This curve will be copied to the sequencer at the same time as the notes you would have edited on the pattern.
- Remove the curve (or a part of it) with the eraser tool.

The graphic edition of the cut-off curve on Arsenic
The potentiometers

The signal

- An LCD screen which graphically represents the wave form used is located on the right side of the instrument. By clicking on the WAVE button, you can define the wave shape of the signal: square or saw tooth.

Click on the WAVE button to change the wave shape

- By turning the WIDTH potentiometer, you can modify the width of the signal in the following manner:

  In the case of a square signal, you will progressively move from “impulse” form to “square”:

  ![Waveform](image)

  In the case of a saw-tooth signal, you will progressively move from a “saw-tooth” to a “double-saw-tooth” form:

  ![Waveform](image)

- The signal is amplitude modulated by an envelope. This envelope can be divided up into two parts: attack and decay.
  - The potentiometer on the left bearing the name ATTACK allows us to set the attack duration (the expansion phase of the sound).
  - The potentiometer on the right bearing the name DECAY allows us to set the decay duration (the decay phase of the sound).

  Two potentiometers which set the attack and decay of the amplitude

The filter

The 5 other buttons allow the configuration of the filter parameters.

What is a filter?

A sound can be broken up into a set of sinus waves with various amplitudes and multiple frequencies of the fundamental. These sine waves are called harmonic waves; the sound spectrum follows this breakdown.

On the first graphic you see the saw-tooth wave and on the second one its spectral representation.
The filter will cut off all frequencies above the cut-off filter frequency:

- The CUTOFF potentiometer lets you choose the filter cut-off frequency, i.e. the level from which higher frequencies will be cut/deleted from the signal. By turning this potentiometer clockwise you can “open the filter”, i.e. you increase the value of the cut-off frequency:

The CUTOFF potentiometer allows you to modify the filter cut-off frequency.
• The second potentiometer called **RESO** characterizes the filter resonance. The resonance allows the definition of the position of the peak. The more the potentiometer is turned clockwise, the higher the filter's peak.

• The third potentiometer bearing the letters **MOD** defines the filter's frequency modulation. As we have just seen, the filter shows an $F_0$ cut-off frequency from which the signal is cut and it is interesting to make this cutoff frequency vary during the note. The value given by the **MOD** potentiometer defines the variation amplitude. The greater the value the stronger the amplitude.

• The **ATTACK** potentiometer controls the attack duration of the variation curve of the cut-off.

![ATTACK and DECAY](image)

*The ATTACK potentiometer shows the attack length of the variation curve of the cut-off frequency.*

• The last potentiometer called **DELAY** allows us to set the decay phase length in the variation curve of the cutoff frequency.

![Attack and Decay Diagram](image)

**The Arsenic contextual menu**

When you right click on this module, you will access a contextual menu:

- **Edit > Pattern** and **Edit > Control**: open the piano roll to edit the patterns or continuous controls for the module.
- **Kepler connection**: connection to or disconnection from the Kepler module.
- **Help**: sends you straight to the help for the module.
- **Clear all patterns**: removes all of the patterns on the module (we can cancel this action with the Undo function).
- **Add a column**: adds a column to the rack.
- **Add a line**: adds a line to the rack.
- **Remove a module**: remove the module from the rack.
- **Effect controls**: adds the effects section on the right of the module.
Bass 52 is a synthesizer which reproduces the characteristics of sound and playing of a fretted electric bass guitar. It will allow you to recreate for example, round and heavy sounds for reggae/dub or R&B bass lines, or more aggressive (metallic or slap) for funk, rock or fusion. This module uses the concept of synthesis by physical modeling. This means that the types of sounds and playing of the instrument (strings muted or slapped, positions of the pick-ups, etc...) were studied and recalculated by computer to allow them to be re-synthesized. This type of synthesis provides a sound faithful to the instrument in its full range and in all forms of expression: change of playing style (soft or aggressive), use of vibrato, etc...

Bass 52 has 64 patterns preprogrammed (or sequences). It consists of two parts:

- The Piano Roll which allows us to program the melody.
- The part on the right of the Piano Roll which lets us configure the sound.

### The melody

This section can be broken into two parts: the pattern selector and Piano Roll.

#### The pattern selector

It functions in the same manner as the other instrument modules of Storm. You can of course modify existing patterns. To do this, you can either take the notes already in the Piano Roll or start from scratch by clicking on the **CLEAR** button. If you wish to return to the original pattern, just click on the **RESTORE** button. If you have already saved your song, the last saved pattern will be the one taken into account.

You can also copy an existing pattern onto one or numerous others (to create evolutions of the original pattern for example). To do this, select the number of the pattern that you want, hit Ctrl+C, select another number and then hit Ctrl+V.

#### The Piano Roll (or pattern composition grid)

This screen helps you to compose a melodic loop. To place a note, click on the grid. To delete, click on the note with the right mouse button (⌘ + click for Mac). To stretch it click on the extreme right, and to move it click on the center of the note and drag it up or down.
The Piano Roll and its four editing modes

To move vertically, slide the vertical bar on the right of the screen up and down. You can also zoom on particular parts of the keyboard to make the notes bigger by shrinking the bar. To do this, click on the top of the bar and slide it downwards.

The different editing modes

The four icons which give access to these are found on the left of the Piano Roll: from top to bottom, you will find volume editing, note editing, the note-link mode and vibrato editing. These different modes appear in the lower part of the Piano Roll.

- **Note editing**, represented by the icon, is, as we have seen in the previous paragraph, to place notes on the Piano Roll. To vertically or horizontally zoom and to move in the pattern, use the lift at the bottom of the Piano Roll.

- **Note link editing**, represented by the icon allows you to link one note to another creating a legato effect (one attack for the two notes). To create links, click on the icon, and then on the first note that you want to link and, without letting go of the left mouse button drag to the second note and release. A red line will appear between the two notes indicating that the link has been formed.

- **Vibrato editing**, represented by the icon allows you to choose the vibrato level for each note. When you enter this mode, all vibrato levels are at zero. To activate one, raise the column under the note that you wish to modulate.

- **Volume editing**, represented by the icon allows you to choose the velocity level for each note. When you enter this mode, all velocity levels are set at an average level. To modify a velocity, move up or down the column under the note for which you wish to change the volume.

Editing on the piano roll

It is also possible to edit Bass 52 patterns and parameters more comfortably with the Piano roll.

To open the piano roll, right click (Control + click for Mac) on the instrument and select the menu **Edit > Pattern** and choose the pattern that you wish to edit from the list.
Configuration of sound

Three parameters allow you to radically change the sound of Bass 52: Attack filter, Vibrato and Release filter.

The sound editing parameters

- **ATTACK FILTER** allows you to configure the absorption of the attack of the note: the more we turn the knob towards the right, the more the attack becomes present, even aggressive (for the “slap” bass sound).
- **VIBRATO** allows you to choose the speed of the vibrato.
- **RELEASE FILTER** allows you to configure the string absorption (the length of the note): the more you turn the knob to the right the more the resonance becomes present, metallic.

The Bass 52 contextual menu

When you right click on this module, you will access a contextual menu:

- **Edit > Pattern** and **Edit > Control**: open the piano roll to edit the patterns or continuous controls for the module.
- **Kepler connection**: connection to or disconnection from the Kepler module.
- **Help**: sends you straight to the help for the module.
- **Clear all patterns**: removes all of the patterns on the module (we can cancel this action with the Undo function).
- **Add a column**: adds a column to the rack.
- **Add a line**: adds a line to the rack.
- **Remove a module**: remove the module from the rack.
- **Effect controls**: adds the effects section on the right of the module.
The Equinoxe chord synthesizer and Arsenic are cousins. They use the same signal generator and the same filter.

The main difference lies in the use of the sound. In the case of Equinoxe the sound is held and several notes can be superposed. This is the reason why three oscillators are offered.

We have to make the difference between the controllers allowing you to work on the sound and the melody control tools, in this case the grid.

**The sound**

**The signal**

The Equinoxe synthesizer produces three-note chords. This is why three independent oscillators are used in parallel.

- The LCD screen located under the WIDTH button lets us visualize the wave shape of each signal from the 3 oscillators.
- To go from a saw-tooth shape to a square shape you only need to click on the WAVE button.

![The wave form visualization screens](image)

- To modify the width of the three signals, use the WIDTH potentiometer.

**The filter and volume envelope**

The filter is the same as in Arsenic. The control parameters are the same: CUTOFF, RESO, MOD, ATTACK and DECAY.

We also find the potentiometers DECAY and RELEASE. Here we control the envelope parameters applied to the volume of the three signals which are added before they pass into the filter.

- DECAY sets the fall time of the volume envelope while the note is held (when the chord is stretched on the grid).
- RELEASE sets the fall time of the volume envelope once the note is released.

Given that the length of the notes is defined on the grid, as we are going to see it, the Decay potentiometer sets their toning down.
The melody

Editing on the programming grid.

The chords are present on the grid located in the middle of the instrument.

The chords are present on the grid located in the middle of the instrument.

The vertical lines represent the 16 beats of the bar.

We are now going to create a chord:

Click on a part of the grid and you will see a chord appear.

• Click on the grid and you will see a 3 note chord representing one beat.
• Click on this chord and stretch it to the right. It is then held on the number of beats between the 2 vertical bars.

Click on this chord and stretch it to the right.

• To erase a chord you only need to click it with the right mouse button (Alt + click for Mac).

The chord defined is a perfect chord, that is to say that it superposes the 1st, 3rd and 5th notes starting from the root note. But you can distort it. For this the procedure is very simple:

• Click on one of the 3 notes making up the chord and move it vertically. The figures located left of the grid define the positions of the notes from the root note. The Kepler defines the root note. (example C Major: C)

• If for instance, you click on the highest note and move it completely up to the upper edge of the grid, you will get a 1-3-8 type chord, meaning that the upper and lower squares define notes by octave.
Moving the higher note increases the chord’s highest note.

The chord being defined, you should be able to transpose it, that is to say to make it higher or lower.

To that end you only need to move the cursor located left of the grid. This cursor offers a 5-octave range.

Moving the cursor located left of the grid transposes the chord.

<table>
<thead>
<tr>
<th>Major chords, minor chords</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>In A minor, 1-3-5 = A-C-E</th>
</tr>
</thead>
<tbody>
<tr>
<td>In A major, 1-3-5 = A-C#-E</td>
</tr>
</tbody>
</table>

Editing on the piano roll

It is also possible to edit Equinox patterns and parameters more comfortably with the Piano roll.

To open the piano roll, right click (Control + click for Mac) on the instrument and select the menu Edit > Pattern and choose the pattern that you wish to edit from the list.

The Equinoxe contextual menu

When you right click on this module, you will access a contextual menu:

- **Edit > Pattern** and **Edit > Control**: open the piano roll to edit the patterns or continuous controls for the module.
- **Kepler connection**: connection to or disconnection from the Kepler module.
- **Help**: sends you straight to the help for the module.
- **Clear all patterns**: removes all of the patterns on the module (we can cancel this action with the Undo function).
- **Add a column**: adds a column to the rack.
- **Add a line**: adds a line to the rack.
- **Remove a module**: remove the module from the rack.
- **Effect controls**: adds the effects section on the right of the module.
The Orpheus module is a synthesizer based on the wave table concept, a type of synthesis that appeared at the beginning of the 80's.

It is a multi-purpose synthesizer which allows us to create melodies (leads for example) and evolving accompaniments, special effects or bass lines.

Orpheus has 64 preprogrammed patterns (or sequences) and 128 presets (or sounds). It is polyphonic for 16 notes, which means that we can program chords containing up to 16 notes.

Orpheus is made up of two major parts:

- the top half which lets us program the melody
- the bottom half which is for programming the sound

### The melody

This part can be divided into two sub-sections: the pattern selector and the Piano Roll.

### The pattern selector

It works in exactly the same manner as the other Storm instruments. You can of course modify the existing patterns. To do this, you can either build on an existing pattern or start from scratch by clicking on CLEAR. If you wish to return to the original pattern, just click on the RESTORE button. If you have already saved the current song, the last saved pattern is the one that will be taken into account.

The Orpheus patterns are, by default, associated with preset sounds. If you wish to modify the sound of a melodic pattern, choose another in the pattern selector and then click on the LINK button for this pattern to be taken into account with yours. For the functions of the sound presets controller, see below.
The Piano Roll (or pattern composition grid)

This screen allows us to compose a sequence of chords (up to 16 simultaneous notes) or a melody. To place a note, click in the grid. To delete it, right-click it. To stretch it, click on the extreme right of the note, and to move it, click in the middle and drag it up or down. To zoom vertically or horizontally on the notes or to move in the pattern, use the scroll-lifts on the bottom (horizontal zoom) and right (vertical zoom) of the Piano Roll.

Use the scroll-lift below the grid
to zoom horizontally on the notes

The Piano Roll equally allows the configuration of a certain number of options for each note. To do this, you must begin by clicking on the icon. The melodic composition zone of the Piano Roll is reduced to a series of columns appearing under the programmed notes. By modifying the height of a column, you influence the control parameters of the corresponding note. These parameters are found by clicking on vol situated at the bottom right of the screen. This mode allows you to edit the values of the volume, filter, and the balance of the oscillators for each note. To return to the note edit mode click on the icon.

Setting the volume of Orpheus notes.

The sound

The work on the sound is done on:

- a group of sound presets
- a two dimension control surface
- a group of preset parameters under the trap
The preset selector

By clicking on the preset selector, you have access to 64 preprogrammed sounds in the synthesizer as well as the 64 in the user presets.

The preset selector.

The wave form control surface

Moving the arrow cursor allows you to progressively change the 4 wave forms of the two oscillators. This permits the creation of progressive and continuous changes to the tone which gives either a subtle or radical evolution to the sound. Without going into detail on the algorithms used, the horizontal movements influence the wave shapes of oscillator 1 and the vertical movements influence oscillator 2.

Configuration of MIDI control

To move among the wave shapes with the help of an external MIDI controller: Ctrl + click (or ⌘ + Click for Macintosh).

The sound creation parameters

You will find them under the Piano Roll, once the trap door is opened (with the help of the OPEN/CLOSE button situated above and to the left of these parameters):

- Oscillators 1 and 2
- The filter
- The filter envelopes and the amplitude
- The LFO's (low frequency modulation oscillators)

The parameters of Orpheus

Oscillator 1

The parameters of oscillator 1
• Its frequency will be directly linked to the note placed on the Piano Roll. To select one of the 32 families of wave shapes (which each have 4 wave shapes), click on the selector, and a menu will appear containing the 32 families.
• To configure the volume balance of the two oscillators, turn the BAL knob to the left to have just oscillator 1, and to the right to have just the sound from oscillator 2. Place it in the middle to have them both. To synchronize the frequency of oscillator 2 with oscillator 1, click on the SYNC button.

Oscillator 2

The parameters of oscillator 2

• The FM button allows the configuration of the rate of modulation of the frequency of oscillator 1 by that of oscillator 2.
• COARSE allows you to choose the note by semi-tone (from -2 octaves to +2 octaves).
• FINE allows the fine-tuning or detuning of oscillator 2 in relation to the frequency of oscillator 1 (by 1/4 tones). A light detuning creates warmer and thicker sounds, particularly for accompaniments.

The filter

The filter parameters

This is a resonant multi-mode filter with a break slope of 12 DB / Octaves.

• The CUTOFF button permits the configuration of the filter break.
• RES defines the resonance rate on the break frequency.
• ENV configures the rate of envelope action on the frequency of the filter break.
• KEYBOARD triggers the keyboard follow for the filter break frequency (This allows us to make the sound more and more bright depending on what is done on the keyboard).

The 4 filter modes: selection of different types of filter. Click until you find what you are looking for.

• LOW PASS cuts the frequencies situated above the frequency of the filter break.
• BAND PASS cuts the frequencies situated below and above the frequency of the filter break.
• HIGH PASS cuts the frequencies underneath the frequency of the filter break.
• NOTCH cuts the frequency of the filter break.

The ADSR envelopes (of filter and amplitude)

The parameters of the two ADSR envelopes
The envelopes represent the route that the signal takes from its beginning to its end. This is how we recognize a short percussive sound in a long and stretched sound. It is brought down to a number of steps:

- **A** (Attack) sets the attack time of a filter envelope or of the volume of a note upon its introduction.
- **D** (Decay) sets the fall time of the filter envelope or of the volume while the note is held.
- **S** (Sustain) sets the level of hold (how long the note will ring) for the filter envelope or volume.
- **R** (Release) sets the fall time of the filter envelope or volume once the note is released.

The 2 LFO’s (low frequency modulation oscillators)

![LFO parameters](image)

An LFO is an oscillator which emits a sound on very low frequency (inaudible). This serves as a cyclic modulator for another sound source. More exactly: a vibrato is an LFO in the form of a sinusoidal wave applied on the pitch of a principal oscillator (the one we hear), it is also the base principle of FM! A Wah Wah effect is an LFO in the form of a sinusoidal wave applied on the cut-off of a resonant filter and a tremolo is the result of an LFO in the form of a sinusoidal wave on the amplitude of a sound.

**LFO 1:**

- The **RATE** button sets the modulation speed.
- **AMOUNT** sets the modulation rate of LFO 1.
- The destination selector of LFO 1 allows us to choose the modulation destination:
  - **CUT**: varies the cut off filter
  - **VOL**: varies the volume
  - **OSC 1**: varies the frequency of oscillator 1
  - **FM**: varies the FM rate on oscillator 2

**LFO 2:**

- The **RATE** button sets the modulation speed.
- **AMOUNT** sets the modulation rate of LFO 2.
- The destination selector of LFO 2 allows us to choose the modulation destination:
  - **BAL**: varies the balance of the 2 oscillators
  - **OSC 2**: varies the frequency of oscillator 2
  - **WAV2**: varies the wave form of oscillator 2
  - **LFO 1**: varies the speed of LFO 1
  - **2 OSC**: varies the frequency of oscillators 1 and 2

**Controlling parameters from an external MIDI source**

As is the case for all of Storm modules, you can assign all of the knobs of Orpheus to a MIDI controller: to do this, hold Ctrl and click on the potentiometer.

**Editing on the piano roll**

It is also possible to edit Orpheus patterns and parameters more comfortably with the Piano roll.

To open the piano roll, right click (Control + click for Mac) on the instrument and select the menu **Edit > Pattern** and choose the pattern that you wish to edit from the list.
The Orpheus contextual menu

When you right click on this module, you will access a contextual menu:

- **Edit > Pattern** and **Edit > Control**: open the piano roll to edit the patterns or continuous controls for the module.
- **Kepler connection**: connection to or disconnection from the Kepler module.
- **Help**: sends you straight to the help for the module.
- **Clear all patterns**: removes all of the patterns on the module (we can cancel this action with the Undo function).
- **Add a column**: adds a column to the rack.
- **Add a line**: adds a line to the rack.
- **Remove a module**: remove the module from the rack.
- **Effect controls**: adds the effects section on the right of the module.
The GMSynth synthesizer offers a great number of sounds based on the general MIDI norm. You will find sounds sampled from acoustic and electronic instruments (piano, bass, brass, violins...). These sounds will then pass through a resonant low-pass filter.

The interface of the instrument module can be separated into two parts:

- The Piano Roll, which is used to program a melodic loop.
- The potentiometers, which are used to work on the sound produced.

**Programming notes**

Note programming can be broken into two parts: the pattern selector and the programming grid.

**The pattern selector**

It works in exactly the same manner as the other instruments in Storm. You can of course modify the existing patterns. For this you can either use the preprogrammed notes in the chord editing grid or start from scratch by clicking on the CLEAR button. If you want to go back to the original pattern just click on the RESTORE button. If you have saved the current song, then the last saved pattern will be the one taken into account. The patterns in GMSynth are associated to programmed sounds by default. If you wish to modify the sound of a melodic pattern, choose another one in the presets selector.

*The GMSynth sound presets*
The note editing grid

This screen lets you compose a melodic loop. To place a note, click on the grid. To remove it, click on the note with the right mouse button (⌘ + click for Mac). To extend it, click on the extreme right of the note and to move it, click on the center and drag it up or down.

It is also possible to change the pattern length: Click on the button.

The note editing grid

To move vertically, move the scroll bar on the right of the screen up or down. You can also zoom on a part of the keyboard to make the notes bigger by reducing this scroll bar. For this, click on the very top of the bar and drag it down.

The editing modes

The two icons that give access to these modes are found on the left of the Piano Roll: from top to bottom you will find the note editing (see image underneath) and volume. The volume editing mode appears in the lower part of the Piano Roll.

- **Note editing**, represented by the icon lets us place notes on the editing grid as we have already seen.

- **Volume editing**, represented by the icon allows us to edit the volume for each note. When you enter this mode, all of the volume values can be configured independently. To change one, raise the column by clicking under the note that you wish to modify. To change the value for each of the notes of a chord separately, click on one of the notes contained and change it. Do the same for the other notes.

Editing the volume

Editing on the piano roll

It is also possible to edit GMSynth patterns and parameters more comfortably with the Piano roll.

To open the piano roll, right click (Control + click for Mac) on the instrument and select the menu **Edit > Pattern** and choose the pattern that you wish to edit from the list.
Configuring the sound

Four parameters allow you to radically change the sound from GMSynth: Bend, Modulation, Cutoff and Resonance.

The 4 sound editing parameters in GMSynth

- **Bend** allows you vary the height of the pitch of the sound. For this, raise or lower the *Bend* wheel.
- **Mod** lets you vary the modulation of the sound so as to obtain a vibrato effect. Raise the *Mod* wheel to hear this effect.
- **Cutoff** is used to vary the GMSynth filter cut-off frequency. By manipulating this potentiometer, you will obtain more or less of a “bright” sound.
- **Resonance** varies the resonance of the GMSynth filter. When you adjust this potentiometer, the sound will begin to “whistle” in a manner of varied pronunciation.

The default Cutoff and Resonance settings

So as not to alter the original sound of the presets, the filter cut-off and resonance settings for GMSynth are set: to the maximum for the *Cutoff* and to the minimum for the *Resonance*.

The GMSynth contextual menu

When you right click on this module, you will access a contextual menu:

- **Edit > Pattern** and **Edit > Control**: open the piano roll to edit the patterns or continuous controls for the module.
- **Kepler connection**: connection to or disconnection from the *Kepler* module.
- **Help**: sends you straight to the help for the module.
- **Clear all patterns**: removes all of the patterns on the module (we can cancel this action with the *Undo* function).
- **Add a column**: adds a column to the rack.
- **Add a line**: adds a line to the rack.
- **Remove a module**: remove the module from the rack.
- **Effect controls**: adds the effects section on the right of the module.
Shadow is a chord synthesizer: An ergonomic interface allows you to quickly and easily create different types of chords: this allows for simple, fast and intuitive programming. The sound is created by a powerful synthesis algorithm which offers rich and varying tones.

This subtractive synthesizer has two oscillators, a noise generator, two Low Frequency Oscillators (LFO) and two envelope controllers. Shadow offers 128 different sound presets which cover the programming possibilities of the underlying synthesizer. The more pertinent settings can be modified in real time thanks to a multi-page control surface and two potentiometers.

As is the case with the other modules in Storm, Shadow has a two-part interface:

- the left side to create the chords
- the right side to modify the sound

### The chords

This part can be divided into two sections: the pattern selector and the chord editing grid.

#### The pattern selector

It works in exactly the same manner as the other instruments in Storm. You can of course modify the existing patterns. For this you can either use the preprogrammed notes in the chord editing grid or start from scratch by clicking on the **CLEAR** button. If you want to go back to the original pattern just click on the **RESTORE** button. If you have saved the current song, then the last saved pattern will be the one taken into account. The patterns in Shadow are associated to programmed sounds by default. If you wish to modify the sound of a melodic pattern, choose another one in the presets selector and then click on the **LINK** button so that it will be linked to the pattern.
The chord editing grid

This grid helps you to program a pattern built up of chords. It's a simple method of pattern programming not unlike that of Equinoxe and allows the creation of several types of chords.

- Choice of pattern length
  On the grid you can choose the number of bars in a pattern. The indicator on the left of the grid allows you select the bar length of your pattern. You can choose 1-2-4-8 bars per pattern. A horizontal scrolling bar allows you to move to the different bars of your pattern. The and buttons on the left of this scrolling bar let you choose the zoom level for the bar display.

- Creating the chord
  To place a chord on the grid, just click on the grid and a perfect chord will be played by default. When you click, holding down the button and moving to the right, you can choose the length of the chord. The length can be changed by clicking on the right hand side of the chord; the mouse pointer will then change to a horizontal double arrow, and you can then increase or decrease the length of the chord.

Removing a chord is simply done with a right click (⌘ + click for Mac) on an empty region of the grid, whereas right-clicking on one note of a chord only removes the selected note. By default, the chord placed is a chord said to be perfect, it is composed of 3 notes. In relation to a C chord, we would have the following notes: C, E (or E flat), G.

- Modifying the chord
  Each chord can be modified with the three menus above the note grid.
  - Among the available settings, the first helps you to choose the type of chord to be edited on the grid. There are 5 types of chord:
    - Type 5 is the default type, places perfect chords automatically.
    - Type 7 allows you to place a minor 7th chord automatically.
    - Type 7M allows you to automatically place a major 7th chord.
    - Type auto is the automatic mode: you can edit a chord by adding, removing or moving a note and this mode automatically determines the nearest chord to the one you have tried to edit based on standard chords.
    - Finally the custom type helps you to freely edit the notes making up your chord by letting you add, move and remove the notes.
• The second type of setting lets you choose to invert or change the octave of a chord on the grid. A click in this zone brings up a table showing for every octave, the inversion settings available for the selected chord.

• The last type of setting (bass) allows you to add a bass one or two octaves below your chord. For example, if you have programmed a perfect chord composed of the notes C3 - E3 - G3 and you click on bass 1, you will add a C2 note to your chord to reinforce it.

• Transposition connection

With this instrument (like Orpheus and H3O+) you can choose to have a transposition connection to the Kepler module, which means that the chord that will be played can by transposed with Kepler’s chord programming. This connection option is active by default, you can deactivate it with a right click (or + click for Mac) in a non sensitive (no buttons or functions) area of the module to access the contextual menu of the module and deselect the Kepler Connection option.

MIDI implementation

The Shadow module can be controlled by a MIDI keyboard and thus can be used as a sound module. On top of this, we can also record the chord grids being recorded in the heart of the pattern in MIDI. The various potentiometers can be controlled by MIDI controllers.

Editing on the piano roll

It is also possible to edit Shadow patterns and parameters more comfortably with the Piano roll.

To open the piano roll, right click (Control + click for Mac) on the instrument and select the menu Edit > Pattern and choose the pattern that you wish to edit from the list.
The sound

The work on sounds is done on:

- a group of sound presets
- a two dimensional control surface
- two controllers

The preset selector

By clicking on the preset selector you access 64 preprogrammed sounds in the synthesizer as well as 64 user presets (Users).

The control surface

The control surface lets you set synthesis setting couples, we can go from page to page with the page break button or by right clicking on the control surface (Ctrl + click for Mac). The control surface is armed with two sliders which help us to move more precisely in the two dimensional control surface.

Configuration of MIDI control

To move on the control surface from an external MIDI controller: Ctrl + Click (or Shift + Click for Macintosh).

The settings for creation of sound

Preset: This selection lets you choose a type of sound that can be attached or not to the current pattern with the Link button. When it is attached, each time that the pattern is selected, the module will use the selected sound. On the other hand, a pattern change will not influence the sound.

CUT: Potentiometer for filter cut-off frequency modification. It allows you to make the sound more or less muffled, more or less bright.

RES: Potentiometer for filter resonance modification. It helps you to bring certain sound frequencies to the forefront compared to others.
**2D Surface**: Control surface where the different pages presented affect two sound settings. The pages are selected by the Mode button and are affected to the following characteristics. The cursor in the center of the surface allows you to modify two parameters, and the two sliders let you modify just one at a time:

**Page 1**: Mix of the two oscillators and noise. When the cursor is at the bottom of the surface, only the two oscillators are present, when it is on the top, the noise is then heard. Moving left to right respectively lets you go from the first oscillator to the second.

**Page 2**: Tuning of the second oscillator. A horizontal movement affects the finer chord, whereas a vertical movement affects the rougher chord which stretches for two or more octaves per semitone.

**Page 3**: Volume envelope. A horizontal movement modifies the extinction of the volume release envelope, whereas a vertical movement changes the attack.

**Page 4**: LFO control. A horizontal movement changes the quantity of filter cutoff frequency modulation, whereas a vertical movement changes that of the height of the pitch (pitch).

**Page 5**: First oscillator wave form. A horizontal movement from the left to the right lets you move progressively from a saw-tooth wave form to a square wave form, whereas a vertical movement affects the impulse width.

**Page 6**: Second oscillator wave form. A horizontal movement from the left to the right lets you move progressively from a saw-tooth wave form to a square wave form, whereas a vertical movement affects the impulse width.

**Mode**: Button to select the pages on the control surface. A page change does not effect the modifications recorded on the other pages.
Horizontal fader: Modification of only the parameter affected by a horizontal movement of the control surface.

Vertical fader: Modification of only the parameter affected by a vertical movement of the control surface.

Link: This button lets us associate or not associate the sound to the current pattern being used. When a preset is attached to a sound, each time the pattern will be selected, the module will use the chosen sound. On the other hand, a pattern change will not affect the sound.

The Shadow contextual menu

When you right click on this module, you will access a contextual menu:

- **Edit > Pattern and Edit > Control**: open the piano roll to edit the patterns or continuous controls for the module.
- **Kepler connection**: connection to or disconnection from the Kepler module.
- **Help**: sends you straight to the help for the module.
- **Clear all patterns**: removes all of the patterns on the module (we can cancel this action with the Undo function).
- **Add a column**: adds a column to the rack.
- **Add a line**: adds a line to the rack.
- **Remove a module**: remove the module from the rack.
- **Effect controls**: adds the effects section on the right of the module.
What is a Drum Machine?

In Storm Music studio, you will find 5 different drum machines. Each one uses different sounds and rhythms, sometimes electronic, sometimes acoustic. These modules are Meteor, Hork, Psion, Puma and Tsunami. The first 4 use samples (we call these sampled drum machines), and Tsunami is a synthesizer that produces sounds that you will trigger.

In Storm, the word instrument has a special meaning to include any equipment capable of generating a melodic line or a rhythm in a studio. This is how the drum machines are integrated into the instrument library even though they do not generate sound, they reproduce samples already recorded. The elements in the synthesizer library will be called instruments or instrument modules even if they are synthesizers in the strict sense of the term or not.

Controlling the drum machines

It is also possible to program drum machines in MIDI, by creating MIDI sequence on the Storm sequencer, on a track corresponding to a drum machine. Each instrument contained in the drum machine will have a space on a MIDI keyboard:

<table>
<thead>
<tr>
<th>METEOR Instruments</th>
<th>Note/ MIDI</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bass</td>
<td>C1 / 36</td>
</tr>
<tr>
<td>Rim shot</td>
<td>C#1 / 37</td>
</tr>
<tr>
<td>Snare</td>
<td>D1 / 38</td>
</tr>
<tr>
<td>Clap</td>
<td>D#1 / 39</td>
</tr>
<tr>
<td>Low Tom</td>
<td>F1 / 41</td>
</tr>
<tr>
<td>Closed Hi Hat</td>
<td>F#1 / 42</td>
</tr>
<tr>
<td>Open Hi Hat</td>
<td>A#1 / 46</td>
</tr>
<tr>
<td>Crash</td>
<td>C2 / 48</td>
</tr>
<tr>
<td>High Tom</td>
<td>D2 / 50</td>
</tr>
<tr>
<td>Ride</td>
<td>D#2 / 51</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>PSION Instruments</th>
<th>Note/ MIDI</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bass</td>
<td>C1 / 36</td>
</tr>
<tr>
<td>Rim shot</td>
<td>C#1 / 37</td>
</tr>
<tr>
<td>Snare</td>
<td>D1 / 38</td>
</tr>
<tr>
<td>Clap</td>
<td>D#1 / 39</td>
</tr>
<tr>
<td>Low Tom</td>
<td>F1 / 41</td>
</tr>
<tr>
<td>Closed Hi Hat</td>
<td>F#1 / 42</td>
</tr>
<tr>
<td>Open Hi Hat</td>
<td>A#1 / 46</td>
</tr>
<tr>
<td>Crash</td>
<td>C2 / 48</td>
</tr>
<tr>
<td>High Tom</td>
<td>D2 / 50</td>
</tr>
<tr>
<td>Ride</td>
<td>D#2 / 51</td>
</tr>
<tr>
<td>Wood block</td>
<td>E2 / 52</td>
</tr>
<tr>
<td>Cowbell</td>
<td>F#2 / 54</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>HORK Instruments</th>
<th>Note/ MIDI</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bass</td>
<td>C1 / 36</td>
</tr>
<tr>
<td>Rim shot</td>
<td>C#1 / 37</td>
</tr>
<tr>
<td>Acoustic Snare</td>
<td>D1 / 38</td>
</tr>
<tr>
<td>Clap</td>
<td>D#1 / 39</td>
</tr>
<tr>
<td>Electric Snare</td>
<td>E1 / 40</td>
</tr>
<tr>
<td>Low Tom</td>
<td>F1 / 41</td>
</tr>
<tr>
<td>Closed Hi Hat</td>
<td>F#1 / 42</td>
</tr>
<tr>
<td>Open Hi Hat</td>
<td>A#1 / 46</td>
</tr>
<tr>
<td>Crash Cymbal 1</td>
<td>C#2 / 49</td>
</tr>
<tr>
<td>High Tom</td>
<td>D2 / 50</td>
</tr>
<tr>
<td>Ride Cymbal 1</td>
<td>D#2 / 51</td>
</tr>
<tr>
<td>Tambourine</td>
<td>F#2 / 54</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>PUMA Instruments</th>
<th>Note/ MIDI</th>
</tr>
</thead>
<tbody>
<tr>
<td>Conga 1</td>
<td>C1 / 36</td>
</tr>
<tr>
<td>Conga 2</td>
<td>D1 / 38</td>
</tr>
<tr>
<td>Cabasa</td>
<td>E1 / 40</td>
</tr>
<tr>
<td>Shaker</td>
<td>F1 / 41</td>
</tr>
<tr>
<td>Derbuka 1</td>
<td>G1 / 43</td>
</tr>
<tr>
<td>Derbuka 2</td>
<td>A1 / 15</td>
</tr>
<tr>
<td>Timb</td>
<td>B1 / 47</td>
</tr>
<tr>
<td>Temp1 (Low Wood Block)</td>
<td>C2 / 48</td>
</tr>
<tr>
<td>Temp2 (High Wood Block)</td>
<td>D2 / 50</td>
</tr>
</tbody>
</table>
### TSUNAMI

<table>
<thead>
<tr>
<th>Instruments</th>
<th>Note/ MIDI</th>
</tr>
</thead>
<tbody>
<tr>
<td>Osc4</td>
<td>C1 / 36</td>
</tr>
<tr>
<td>Osc3</td>
<td>D1 / 38</td>
</tr>
<tr>
<td>Osc2</td>
<td>E1 / 40</td>
</tr>
<tr>
<td>Osc1</td>
<td>F1 / 41</td>
</tr>
<tr>
<td>Noise4</td>
<td>G1 / 43</td>
</tr>
<tr>
<td>Noise3</td>
<td>A1 / 15</td>
</tr>
<tr>
<td>Noise2</td>
<td>B1 / 47</td>
</tr>
<tr>
<td>Noise1</td>
<td>C2 / 48</td>
</tr>
</tbody>
</table>

On all of the drum machines we can also apply **mute** and **solo** functions independently for each instrument:

By clicking on the name of the instrument, like the snare drum or the tom, you cut the sound of this instrument (MUTE), while the others contained in the same drum machine will continue to play. By clicking a second time, you reactivate the sound of the instrument (UNMUTE).

In the same manner, by right clicking (⌘ + click on Mac) on the name of an instrument, you play the instrument as SOLO. It's an inverted MUTE: you cut out all other instruments of the drum machine excepting the one you have selected. By clicking a second time on the name of the instrument, you remove the SOLO function. It is possible to use several MUTE or SOLOS at the same time as with traditional mixing tables.

---

*Click with the right or left mouse button on the name of an instrument*
The Tsunami drum machine, unlike other modules of the same type which use samples, generates sounds by synthesis like the first 70's drum machines.

As for the synthesizers, part of the presentation is dedicated to the programming of new loops and one part is dedicated to the sound produced.

### Programming a rhythm

The first thing to do in order to hear and modify sound is to program a rhythm! (or use pre-programmed patterns)

Programming a new rhythm grid is fairly easy:

- Start by erasing the current pattern: click on the grid and click on CTRL + X or click on the CLEAR button under the pattern selector.
- Next, click on any bulb in the grid and a green light will be on. This green light corresponds to a percussion sound.

The small red lines above the grid correspond to the four beats of the bar. This is the same for all Storm drum machines.

**Click on one bulb in the grid and a green light will come on.**

- When clicking a few times on the same bulb the volume of the associated sound changes. Storm manages the dynamics for each sound in the grid regardless of the others.
The dynamics of a sound in the grid follows the cycle below:

- Bulb off: no sound
- 1st left click: weak sound
- 2nd left click: average sound
- 3rd left click: rather strong sound
- 4th left click: very strong sound

When using the right click the cycle goes in reverse.

What does each bulb correspond to?

Switching on a bulb comes down to choosing the sound of the corresponding instrument on the corresponding beat.

The various instruments offered are broken into columns left of the grid. The various beats of the bar are in a line above the grid. Each bulb thus corresponds both to a beat and a bar.

It is also possible to edit Tsunami patterns with the help of a “piano roll” type editing grid specially conceived for drum machines.

To open the piano roll, right click (Control + click for Mac) and select the menu Edit > Pattern and choose the pattern that you wish to edit from the list.
Select the pattern to edit

- To edit the pattern, use the “Drawing” tool and click on the grid to display the notes corresponding to the instruments.
- To remove a note, use the “Eraser” tool and click on the note.
- It is possible to change the volume for each note with the volume editor just under the Piano Roll. Raise or lower the column below the note.

Editing a pattern.

The lower part of the Piano Roll lets you graphically edit the curve of a given Tsunami potentiometer.

Choose the parameter that you wish to edit from the list and draw the curve with the drawing tool. This curve will be copied to the sequencer at the same time as the notes that you will have edited in the pattern.
Working on the sounds

The Tsunami drum machine achieves all of the sounds offered by synthesis. This means that it is possible to substantially modify its parameters.

A series of potentiometers is associated to each instrument, the name of which is stated on the right of the grid.

Actually two types of sounds can be created from two different sources: The first four instruments from the top containing white noise. The last four; a sinusoidal wave oscillator.

For each of the sounds you can set a large number of parameters.

In the case of the noise sounds (white noise), let us analyze the controlled parameters. For that click on the blue diode on the right of Noise 1 (the diode lights up red).

• **Pan** allows the setting of the panoramic distribution of the sound.
• **Lev** controls the dynamics of the selected sound, i.e. its volume.
• **A**: this is the attack applied to the noise.
• **D**: this is the Decay of the envelope.

The sound created is then modulated by a band-pass filter:
F is the cut-off frequency of the filter (F0).
Res is the filter’s peak value.

In the case of oscillators (sinusoid) there are 7 potentiometers:

- Lev and Pan have the same function as above. The oscillator’s frequency is defined by the Pitch button.
- MA is the attack duration
- MD is the duration of the decay phase of the sound
- Md defines the amplitude of the frequency modulation
- D corresponds to the Decay associated with an amplitude envelope applied this time directly to the sound.

The Tsunami drum machine is very complete and in a sense fairly complex. But it offers enormous possibilities for creation.

Besides this, it offers a feature which memorizes the potentiometer movements in the patterns.

You can also edit the curve of the different potentiometers with the controller editor which is found under the note grid. Choose the control that you wish to edit from the list of potentiometers and modify the curve with the drawing tool.

Editing controllers.
Instrument control

You can control each of the 8 instruments that make up the Tsunami drum machine in different manners:

- by MIDI
- by using the MUTE and SOLO functions of each instrument
- with the numerical keyboard

These control techniques are the same for all 5 drum machines in Storm. To find out more take a look at the introduction chapter to drum machines.

The Tsunami contextual menu

When you right click on this module, you will access a contextual menu:

- **Edit > Pattern** and **Edit > Control**: open the piano roll to edit the patterns or continuous controls for the module.
- **Help**: sends you straight to the help for the module.
- **Clear all patterns**: removes all of the patterns on the module (we can cancel this action with the Undo function).
- **Add a column**: adds a column to the rack.
- **Add a line**: adds a line to the rack.
- **Remove a module**: remove the module from the rack.
- **Effect controls**: adds the effects section on the right of the module.
The Meteor drum machine provides you with an ensemble of sounds which have been sampled from analog drum machines.

Programming rhythms

The programming grid

The programming of rhythms is identical to that of the Tsunami sound module. It uses the bulb grid.

The list of instruments offered is the following:

- Bass Drum (BASS)
- Snare Drum (SNARE)
- Hand Clap (CLAP)
- open Hi Hat (HAT O)
- closed Hi Hat (HAT C)
- “Ride” Cymbal (RIDE)
- Tom (TOM)
- “Crash” Cymbal (CRASH)

Compared to the previous drum machine there are some differences as regards to working on sounds:

The potentiometers are always gathered in pairs. And here also a pair of potentiometers corresponds to an instrument.

- The first potentiometer allows us to set the sound pitch. The pitch corresponds to the tone according to which the sample is read. The higher the pitch of the sample, the shorter the sound and playback is. This parameter can be interesting for example to change the height of the toms. Turn the potentiometer to one side or the other and you should hear this difference.
- The second potentiometer Dec controls the sound decay.

The movement of these buttons corresponding to the two parameters can be recorded within the pattern.

The first potentiometer controls the pitch,
the second the sound duration (decay).
Editing on the piano roll

It is also possible to edit Bass 52 patterns and parameters more comfortably with the Piano roll.

To open the piano roll, right click (Control + click for Mac) on the instrument and select the menu Edit > Pattern and choose the pattern that you wish to edit from the list.

Instrument control

You can control each of the 8 instruments that make up Meteor in 3 different manners:

- by MIDI
- by using the MUTE and SOLO functions of each instrument
- with the Piano Roll editor

These control techniques are the same for all 5 drum machines in Storm. To find out more take a look at the introduction chapter to drum machines.

The Meteor contextual menu

When you right click on this module, you will access a contextual menu:

- Edit > Pattern and Edit > Control: open the piano roll to edit the patterns or continuous controls for the module.
- Help: sends you straight to the help for the module.
- Clear all patterns: removes all of the patterns on the module (we can cancel this action with the Undo function).
- Add a column: adds a column to the rack.
- Add a line: adds a line to the rack.
- Remove a module: remove the module from the rack.
- Effect controls: adds the effects section on the right of the module.
The Psion drum machine provides you with an ensemble of sounds sampled from electronic drum kits.

**Programming rhythms**

**The programming grid**

The [programming of the rhythms](#) is identical to that of the Tsunami module.

The list of instruments offered is the following:

- Bass Drum (BASS)
- Snare Drum (SNARE)
- Hand Clap (CLAP)
- closed Hi Hat (HAT C)
- open Hi Hat (HAT O)
- Ride Cymbal (RIDE)
- Toms (TOM)
- Cowbell (COW)

The potentiometers are always gathered in pairs. And here too a pair of potentiometers corresponds to an instrument:

- The first potentiometer allows us to set the sound pitch. The pitch corresponds to the tone at which the sample is read. The higher the pitch of the sample the shorter the sound and playback are. This can be interesting for example to increase the height of the toms. Turn the potentiometer to one side or the other and you should hear this difference.
- The second potentiometer controls the sound decay.

Movements of each controller are recorded within the pattern.

The first potentiometer controls the pitch, the second controls the decay.

**Editing on the piano roll**

It is also possible to edit Bass 52 patterns and parameters more comfortably with the Piano roll.

To open the piano roll, right click (Control + click for Mac) on the instrument and select the menu Edit > Pattern and choose the pattern that you wish to edit from the list.
Instrument control

You can control each of the 8 instruments that make up the Psion drum machine in different manners:

- by MIDI
- by using the MUTE and SOLO functions of each instrument
- with the Piano Roll editor

These control techniques are the same for all 5 drum machines in Storm. To find out more take a look at the introduction chapter to drum machines.

The Psion contextual menu

When you right click on this module, you will access a contextual menu:

- **Edit > Pattern** and **Edit > Control**: open the piano roll to edit the patterns or continuous controls for the module.
- **Help**: sends you straight to the help for the module.
- **Clear all patterns**: removes all of the patterns on the module (we can cancel this action with the Undo function).
- **Add a column**: adds a column to the rack.
- **Add a line**: adds a line to the rack.
- **Remove a module**: remove the module from the rack.
- **Effect controls**: adds the effects section on the right of the module.
This is another sampled drum machine offered in the instruments library. Puma offers traditional and exotic percussion sounds.

Programming rhythms

The programming grid

The programming of rhythms is identical to that of the Tsunami sound module. It uses the bulb grid.

The list of instruments is as follows:

- Low Conga (CONGA 1)
- High Conga (CONGA 2)
- Cabasa
- Shaker
- Low Derbuka (DERB 1)
- High Derbuka (DERB 2)
- Timbale (TIMB)
- Temp

For each sound, a pair of potentiometers allows to reprocess the sound:

- The first potentiometer allows to you set the pitch of the sound. The pitch corresponds to the tone at which the sample is read. The higher the pitch, the faster it is read and the shorter its length. This can be interesting for example for changing the height of percussions.

- The second potentiometer allows us to set the decay of the sound, i.e. the duration of the sound decay or simply its length.

Editing on the piano roll

It is also possible to edit Bass 52 patterns and parameters more comfortably with the Piano roll.

To open the piano roll, right click (Control + click for Mac) on the instrument and select the menu Edit > Pattern and choose the pattern that you wish to edit from the list.
Instrument control

You can control each of the 8 instruments that make up the Puma drum machine in different manners:

- by MIDI
- by using the MUTE and SOLO functions of each instrument
- with the Piano Roll editor

These control techniques are the same for all 5 drum machines in Storm. To find out more take a look at the introduction chapter to drum machines.

The Puma contextual menu

When you right click on this module, you will access a contextual menu:

- Edit > Pattern and Edit > Control: open the piano roll to edit the patterns or continuous controls for the module.
- Help: sends you straight to the help for the module.
- Clear all patterns: removes all of the patterns on the module (we can cancel this action with the Undo function).
- Add a column: adds a column to the rack.
- Add a line: adds a line to the rack.
- Remove a module: remove the module from the rack.
- Effect controls: adds the effects section on the right of the module.
The Hork drum machine offers an ensemble of sounds sampled from a real acoustic drum kit.

![Hork Drum Machine](image)

**Programming rhythms**

**The programming grid**

The list of instruments offered is the following:

- Bass Drum (BsDr)
- a first Snare Drum (SNR 1)
- a second Snare Drum (SNR 2)
- rim shot (RIM)
- closed Hi Hat (Hh Cl)
- open Hi Hat (Hh Op)
- toms (TOM)
- “Crash” and “Ride” cymbals (CYMB).

The potentiometers are always gathered in pairs. And here too a pair of potentiometers corresponds to an instrument:

- The first potentiometer allows us to set the pitch of the sound. The pitch corresponds to the speed at which the sample is read. The faster the sample is read, the shorter the sound is. This parameter can be interesting for example to change the height of the toms. Turn the potentiometer to one side or the other and you should hear this difference.
- The second potentiometer controls the decay of the sound.

The movement of the buttons corresponding to these two parameters can be recorded within a pattern.

![Pitch Dec](image)

*The first potentiometer controls the sound pitch, the second potentiometer controls the sound decay.*

**Editing on the piano roll**

It is also possible to edit Bass 52 patterns and parameters more comfortably with the Piano roll.

To open the piano roll, right click (Control + click for Mac) on the instrument and select the menu Edit > Pattern and choose the pattern that you wish to edit from the list.
Instrument control

You can control each of the 8 instruments making up Hork by 3 different manners:

• by MIDI
• by using the MUTE and SOLO functions of each instrument
• with the Piano Roll editor

These control techniques are the same for the 5 drum machines in Storm. To find out more take a look at the introduction chapter to drum machines.

The Hork contextual menu

When you right click on this module, you will access a contextual menu:

• Edit > Pattern and Edit > Control: open the piano roll to edit the patterns or continuous controls for the module.
• Help: sends you straight to the help for the module.
• Clear all patterns: removes all of the patterns on the module (we can cancel this action with the Undo function).
• Add a column: adds a column to the rack.
• Add a line: adds a line to the rack.
• Remove a module: remove the module from the rack.
• Effect controls: adds the effects section on the right of the module.
Recording, playing, editing, scratching an audio sample in Storm

The sample modules allow you to use samples recorded in formats such as WAV, MP3 or AIFF in the studio. These modules are H30plus, Scratch (the mix and scratch table), and EZtrack.

In Storm, the word instrument has a particular meaning as it is applied to any device capable of producing a melodic or rhythmic line in the studio. This is why the three sample modules are included in the instrument library, even though they do not generate sound but reproduce and modify pre-recorded samples.

To find out more about using samples in the studio, see the Chapter Using samples.

In the Storm STM file format, samples are the elements which take up the most space, especially when they are not compressed, even though the studio and sound characteristics for the synthesizers and drum machines can be contained in just a few kilobytes. It is nonetheless possible to integrate them into the STM file. To find out more see the Chapter loading/saving.

Finally, in Storm Music Studio 3.0, you can use the Hall to look for and exchange samples with other users. Don’t hesitate in making use of this opportunity!
The EZtrack module allows you to record any external audio source (through microphone, line in, CD etc.) in synchronization with the other Storm modules. The recorded samples can be replayed (with real-time time-stretching in case of a change in tempo), edited and exported to other modules. Recording with EZtrack is done by one of two means, either in normal mode or punch mode.

- **Play-back with real-time time-stretching**
- **Recording in punch mode**
- **Recording on the fly**
- **Thru mode deactivated**
- **Replacement and mixing modes**
- **Select the audio input recording source**
- **Select, edit and export samples**

### Choosing the external audio source

Clicking on the EZtrack SOURCE brings up a mixing table which allows you to select the external input source and the entry level. Make sure you set the entry level so as to have a sufficiently strong sound while avoiding saturation.

Two different scenarios can appear here:

- **PC / Direct X**: If you work on PC, and you have configured Storm to use DirectX drivers, the SOURCE button will open the Windows multimedia mixer in recording mode. All you need to do is select one of the sources and set the volume of recording coming in to EZtrack. Now close the Windows mixer: EZtrack is ready to record.
Select your audio sources on the Windows mixer and set the volume with the fader.

• Mac OS + Sound Manager / Mac OS X + Core Audio / ASIO for PC or Mac: if you are in one of these audio configurations, the SOURCE button will open a Storm interface which will allow you to perform the same settings as with the previous case: choice of recording source and volume recording level.

Select your audio sources on the EZtrack mixer and set the volume with the fader.

Recording in normal mode

To start recording in normal mode, make sure that punch mode is deactivated by clicking on the word punch on the editing bar (a dark orange color tells you that the punch mode is off). You can then click on the REC button. This flashes until the start of the next bar - recording will only start at the start of a bar. Then you’ll see the signal appear on the module as it is recorded. To end recording, press PLAY - the EZtrack module goes into play mode and plays back your recording while the sequencer goes back to the same part of the song.
Recording in punch-in/punch-out mode

Activate punch mode by clicking on the top part of the editing bar - click on the PUNCH indication to activate / deactivate the punch, click to position the start of the punch on a given bar, right click (⌘ + click for Mac) to position the end of the punch. Click on the REC button - it will flash until the cursor arrives at the marker showing where the punch starts, which starts the recording. Then you will see the signal appear on the module as it is recorded. When the cursor arrives at the end of the punch, EZtrack goes automatically into play mode.

Replacement or mixing with the previous recording

The erase button allows you to choose one of the two following modes:

- **Erase** mode (the ERASE button is depressed): A recording in a previously recorded bar will completely erase the previous recording and replace it with the new one.

- **Mix** mode (the ERASE button is released): A recording will be automatically mixed with any recording already done in the same bars.

Editing

The recorded samples can be edited: to create a selection left click outside the existing selection, then slide the cursor to the end of the selection. The options **Cut** / **Copy** / **Paste** in the **Edit** menu allow you to cut, copy and paste bits of your recording to other parts of the song.
Exporting to another module

A selection in the EZtrack editor can be very easily exported to another module (Scratch or H30plus) by simply dragging and dropping (for example onto a turntable, on the H30plus grid or onto another EZtrack).

![Image of EZtrack and H30plus](image)

*Exportation of an audio section from the EZtrack editor to H30plus*

The EZtrack contextual menu

When you right click on this module, you will access a contextual menu:

- **Edit > Control**: open the piano roll to edit the continuous controls for the module.
- **Help**: sends you straight to the help for the module.
- **Add a column**: adds a column to the rack.
- **Add a line**: adds a line to the rack.
- **Remove a module**: remove the module from the rack.
- **Effect controls**: adds the effects section on the right of the module.
H3OPLUS

H3O+ is a sample sequencer that offers the opportunity to introduce samples into your composition, in parallel with the real time synthesis.

How does it work?

Besides using the pattern selector allowing you to call on pre-programmed sample sequences, it is obviously possible to create your own sequences on the 4 available tracks of the module.

- To do this, open the sample library in the explorer (click on the “Samples” tab to have it appear).

- Choose a first sample among the samples provided in the sample library or among those you may have dropped in the container
- “Drag and drop” it onto the sequencer.

Drag and drop the sample onto the sequencer from the library...
You are not, however, obliged to use the sample library, even though it is very useful for organizing and stocking your samples inside a composition. You can also drag-and-drop any file (WAV, MP3 or AIFF) available in your computer onto H30plus:

...or from any location on the hard drive.

The control of the tone and tempo of the sample

Storm relies on a time-stretching algorithm in real time so as to enable a tempo or tonality change to the sample in real time. But it is necessary that the original tempo and tonality of the sample be specified in the sample properties dialog box.

- To make sure, right click on the sample open in the sequencer.
- Sample properties is now displayed.

- Check that a value is present for the tempo, that the number of “steps” is correctly set (this is the length of the sample in 16ths of a bar), and that a tone is selected if the sample is tuned.
- If this is the case this means that the sample tone and tempo are already written in its properties.
• If not, select a key from the list. Give a value to the tempo by clicking on it and using the arrows (this will let us synchronize the sample with the Scratch module). Finally set the number of steps so that the sample has the right length in H3O+.

You can now try to change the sample tempo or tone of a sample. You can also decide not to apply the automatic functions of time-stretching and pitch-shifting. For this, click on one or the other of the options to be checked Deactivate time-stretching and Deactivate pitch-shifting. Thus the samples imported into your compositions will keep their original tempo and tone.

Changing the tempo:

• the sample tempo uses the general tempo and thus you only need to modify the value in the tempo window of the control bar.

![Tempo window](image)

*The sample tempo is automatically set to that of the control bar.*

• It can also happen that Storm does not correctly understand the length of imported samples. You can set this by using the Steps value situated above the tempo in sample properties. A step corresponds to 1/16th of a bar, you need for example 16 steps to make a bar of 4 beats.

![Steps](image)

*Steps allows you to set the length of samples*

• It is also possible to change the length of samples directly on H30plus by dragging the extreme right of the sample with the mouse.

![Sample length](image)

*Drag the right of the sample to change the length*

Changing the key:

![Key module](image)

*The key of the sample is given by the Kepler module.*
To change the tone you only need to program a series of modulations on the Kepler module. The sample tone is set on the Kepler module as for all modules (except drum machines which are not melodic) managed by Kepler.

So that the effect Kepler has on the samples placed on H3O+ is correct, the original tone of the sample needs to be configured in the properties window:

![Properties Window](image)

*Tone allows you to transpose your sample.*

- To close the sample properties, you only need to click beside it.
- You can also transpose the samples individually. This can be interesting for creating a “brass section” effect from one sax sound for example. For this, hold Shift + Click on a sample that you want to tune; a small horizontal Transpose keyboard will appear. Choose the tone and click outside the keyboard to close it.

![Transpose Keyboard](image)

*The keyboard in H3Oplus allows you to transpose individual samples.*

**Controlling the volume of each sample:**

The volume of each sample can be controlled independently of the other samples selected. For this, click on the extremity of the sample and decrease its height by moving the mouse down.

![Volume Control](image)

*Drag the upper part of the sample and drag it down to reduce the volume.*

**Duplicating a sample**

To duplicate a sample, keep key CTRL pressed, click on the sample and “drag and drop” it to a new place.
When you right click on this module, you will access a contextual menu:

- **Edit > Control**: open the piano roll to edit the continuous controls for the module.
- **Kepler connection**: connection to or disconnection from the Kepler module.
- **Help**: sends you straight to the help for the module.
- **Clear all patterns**: removes all of the patterns on the module (we can cancel this action with the Undo function).
- **Add a column**: adds a column to the rack.
- **Add a line**: adds a line to the rack.
- **Remove a module**: remove the module from the rack.
- **Effect controls**: adds the effects section on the right of the module.
This is a double deck that a DJ may use. It allows you to mix and scratch your samples.

Scratch allows you to mix and scratch in real time.

How to load new records on the deck?

- Open the sample container and select the sample you wish to drop on one of the decks.
- Drag and drop it onto the deck.
- It is now loaded.

When a new sample is dropped on the deck it is automatically set to the rhythm of the piece. The original tempo of the sample, seen in the properties window of the sample, is not applied.

What are the various controllers used for?

The sample length selector

To respect the loop concept in Storm you can decide on how many bars your sample will be looped. For that you only need to click on the arrows of the controller located above the deck. However, if you leave the controller in position 0, the entirety of the sample is read.

The controller located above the deck allows you to choose the number of bars before the loop.

The fader

The fader works like normal hardware DJ mixing tables and allows you to select a deck and then the other.

The fader works as on hardware DJ mixing decks.

The pitch sliders

Both sliders located on the sides of the mix table allow you to change the records’ rotation speed, i.e. the sample pitch.
Both external faders allow the modification of the records playback speed.

This reading speed is at the beginning set so that the sample follows the same rhythm as the other elements of the studio. If you move the pitch slider it will be difficult to get the original position back. Nevertheless the slider will be instantly repositioned if you apply a right click on the pitch slider.

On/Off buttons

These buttons allow you to stop the motor of the decks. What are they useful for?

It is sometimes interesting to scratch a precise part of a sample, a voice for example. For that you can click on the On/Off button and position the record by hand on this sound. You only need to click on the record and keep your finger pressed while moving the mouse to the top of the screen.

The On/Off buttons allow you to position the record in a precise place.

How can I mix existing songs?

You only need to import your songs in the MP3 or WAV format as we have seen in the previous page.

The Scratch contextual menu

When you right click on this module, you will access a contextual menu:

- **Edit > Control**: open the piano roll to edit the continuous controls for the module.
- **Help**: sends you straight to the help for the module.
- **Add a column**: adds a column to the rack.
- **Add a line**: adds a line to the rack.
- **Remove a module**: remove the module from the rack.
- **Effect controls**: adds the effects section on the right of the module.
EFFECTS BASICS

What is an effect?

Shortly, we can say that it is a function of sound deformation. Reverberation, for example which is going to make the sound produced by an instrument hoarser, larger, is a sound effect. Delay, which allows the addition of an echo to the sound produced is another. Where the synthesizers are going to create sounds, the effects will deform them.

![Diagram of Synthesizer to Effect]

In the studio the effects available are located to the left side of the rack in the effect library. As is the case with the instruments, it is possible to place them in the rack... as many as your computer can handle! Certain effects “consume” more CPU load than others (like Reverb, Compressor or Vocoder for example). This CPU load is indicated in the effect library, on the right underneath the effect image.

Linking the effects

When at least one instrument and one effect are installed in the rack, it is possible to send the sound from the instrument to the effect. For this you need to use the effect send extension which is found either on the mixing table (second “level” of the table), or directly on the rack on the right of the instrument (in the case where the display of effect sends in the rack is activated). The effect send extension contains three digital displays indicating the names of the three effects towards which the sound from the instrument can be sent (or “None” in the case where no effect is selected), as well as three potentiometers setting the level being sent to each effect. Click on one of the digital displays and select an effect in the dropdown menu that appears, and set the send level with the corresponding potentiometer.
It is also possible to link several effects at the output of a Storm instrument module.

To that end you only need to redirect the sound produced by the first effect towards a second effect by opening the corresponding effect send output on the first effect module.

Select the first effect on the instrument module

Select the second effect on the right of the first effect

It is possible to link any number of effects.

Possible configurations

Two instrument modules are sent to the same effect:

The sound of the two instruments is mixed before being sent to the effect.

It should also be noted that the mixing table sliders control the volume of the synthesizers before passing through the effect.

One of the two instruments has already passed into an effect:

The sound is mixed before passing into the second effect.

“Pre” / “Post” Configurations:
You can choose to send the effect input before (“pre” - button of the effect send lighting) or after (“post” - button off) the volume fader and panoramic of the instrument.

In the position with PRE activated, you will still hear the sound entering the effect when the instrument volume fader of the instrument is lowered (the “raw” sound from the instrument will have disappeared). If this is not the case, you won’t hear sound anymore when you set the instrument volume fader to zero.
Presentation of Chorus

Chorus is a very simple effect that can produce impressive results.

Concept:

The input signal is duplicated. This duplicated signal is played in parallel with the original signal with a variable delay. The value of the delay varies according to a defined frequency.

Finally, the duplicated signal is partly reintroduced at the beginning of the effect.

Controllers:

- The SPEED potentiometer controls the variation frequency of the delay.
- The WIDTH potentiometer controls the maximum amplitude of the delay.
- The FEEDB potentiometer allows us to control the percentage of the shifted signal reintroduced as input to the effect.

The preset selector above the 3 controllers lets us use preconfigured chorus configurations with predefined SPEED, WIDTH and FEEDB values. Each preset changes the type of chorus used (stereo more or less large, for example). There are 8 of these presets and they cannot be modified by the user.

The Chorus contextual menu

When you apply a right click to this module (Ctrl + Click for Mac), you will access a contextual menu:

- Edit > Control: opens an editor for the module continuous controllers.
- Help: sends you straight to the help for the module.
- Add a column: adds a column to the rack.
- Add a line: adds a line to the rack.
- Remove module: removes the module from the rack.
- Effect controls: displays or hides the effect sends in the rack.
Compression is an effect used by sound engineers to control sound levels and also to shape the dynamics of an instrument. Unlike other more spectacular effects, more creative on a compositional level, the compressor is an effect of sound creation.

With the Compressor, you can make the sound volume levels more dynamic without the risk of saturation; you can amplify the attack of an instrument which is weak to give it more “punch”.

On the other hand, don't count on the Compressor to make the earth move. As the composer Gustav Mahler once said: “When we can hear trombones, it means they're playing too loudly”, the same is true for the Compressor wherein the effect must be discrete without being identifiable as such.

A little theory...

As we all know, sound can be classified by among others its volume or sonar level. Increasing or decreasing the level of sound or music is done simply by turning the dial on your HIFI. If this modification is affected in function with the level of the music, which is to say if we decrease the volume when it is too high and increase the volume when it is low, we do the work of a compressor.

In more detail, the Compressor lowers the sound level when it exceeds a certain limit called a “threshold”. The means by which the Compressor lowers the sound is in relation to the rate of compression, also called “ratio”. A ratio of 1 will not lower the sound, a ratio of 0.5 lowers the sound by a ratio of 2, a ratio of 0 will theoretically stop the sound from exceeding the limit which enables the Compressor.

When you perform compression with the volume of the amplifier, the effect is not instantaneous, there is a delay time between when you hear the sound passing the limit and when you turn the volume. The same is true for the compressor. The time between the moment that the sound exceeds the limit and the moment where the compressor lowers the sound is called “attack”. In the same manner, the delay between the moment where the sound is beneath the limit and the moment where the Compressor ceases to react is called “release”.

If the Compressor only lowers the sound, how can it be used to increase the sound volume without saturation? It's quite simple, after having decreased the parts that are too loud, all you need to do is increase the whole of the sound. The level is increased, the parts that were too loud have been forced down, there is no saturation!!

An illustration...

The incoming signal is a sine curve which passes sharply from a level well above the “threshold” to a level well underneath... the bold line represents the level of the signal:
The factor for increasing volume is called “gain”. A gain of 0.5 indicates that the volume is halved, a gain of 0 means that it is silenced, a gain of 1 will not change the signal.

The theoretic gain, the case of a ratio of 0 (maximum compression) is represented by the bold line, underneath is the theoretic signal output. We see that the gain is lowered once the volume of the signal is stronger which allows the output signal to stay under the threshold:

A fixed gain is thus applied to the output signal and the diagram shows the means by which the attack of the sound has been strongly increased and equally for the weak input signal:
The module...

There are three commands on the compressor: **attack**, **release**, **gain** and a display indicating the signal level.

- On the screen, we see two red lines, two arrows and a clear-blue line. The first arrow, placed on the bottom of the screen allows you to modify the threshold, the second, which is on the right is for changing the ratio.
- By moving the arrows, the two lines follow the movement, representing the signal compression curve. The level represented horizontally corresponds to the input signal, the vertical corresponds to the output signal.
- Thus we see that the level is not modified before the limit is reached, the line is perfectly oblique with a slope of 1. On the other hand, the line which links this limit and the ratio arrow has a slope corresponding to the desired ratio. When it is horizontal, the ratio is 0 and compression at the maximum.
- A red point hops above the red lines. It represents the peak level of the output signal. As the diagrams above show, the higher the attack time, the more the red point will be distanced from the theoretic compression curve. Finally it represents the attack peak level.
- The third line, clear-blue, represents the 0 dB level (the limit of digital saturation) after the application of the output gain. This line is modified by the **GAIN** fader. When the output signal exceeds this line, the red diode on the top of the screen will light up, the green diode shows an output level without saturation (clip).
- The attack and release times are modified by the **ATTACK** and **RELEASE** dials and the **BYPASS** button allows you to quickly short-circuit the effect to easily control by ear the effect of the Compressor on the original sound.
- The **CLIP** diode turns red when the output signal exceeds 0 dB.
When you apply a right click to this module (Ctrl + Click for Mac), you will access a contextual menu:

- **Edit > Control**: opens an editor for the module continuous controllers.
- **Help**: sends you straight to the help for the module.
- **Add a column**: adds a column to the rack.
- **Add a line**: adds a line to the rack.
- **Remove module**: removes the module from the rack.
- **Effect controls**: displays or hides the effect sends in the rack.
Presentation of Distortion

Distortion is originally an undesirable alteration of the sound signal: the signal is saturated on output and the sound seems to be deformed.

But distortion is also used in numerous musical styles where the roughness added to the sound is appreciated.

Concept:

The signal is dirtied, distorted; if the specter is observed, it is enriched by numerous harmonics.

Controllers:

- The DRIVE potentiometer increases or decreases the signal deformation.
- The GAIN potentiometer allows us to set the volume coming out of the effect. Using it is not the same as the volume on the mixing table. GAIN helps us to correct the inevitable increase in volume of the sound coming out of the effect when the DRIVE parameter is set to high values.

The two signal meters on the right of the DRIVE and GAIN buttons allow us to visualize the volume saturation level, the ideal would be to use the GAIN potentiometer to keep the highest points out of the red zone.

The Distortion contextual menu

When you apply a right click to this module (Ctrl + Click for Mac), you will access a contextual menu:

- Edit > Control: opens an editor for the module continuous controllers.
- Help: sends you straight to the help for the module.
- Add a column: adds a column to the rack.
- Add a line: adds a line to the rack.
- Remove module: removes the module from the rack.
- Effect controls: displays or hides the effect sends in the rack.
Delay is one of the most widely used effects in the musical world. It allows you to prolong a note by creating an echo. The result is an effect of space and volume.

The Storm Dual Delays module allows you to largely configure this effect as there are two delays, one which influences the left speaker, the other is for the right speaker.

Two effects in one

Dual Delays is composed of two delay effects. One of them sets only the echo on the right speaker (RIGHT), and the other corresponds to the left speaker (LEFT). They are identical and each have 3 controllers:

- **STEPS:** sets the number of sequencer steps (semi-quavers) between the sound emitted by the instrument and the response (echo)
- **The LEFT and RIGHT potentiometers:** take the case of the RIGHT delay. The RIGHT button lets us set the echo of the RIGHT delay, which is to say the right speaker. The LEFT button sends this same echo, which has just passed through the RIGHT delay towards the LEFT delay to give a second delay. The two buttons of the LEFT delay work in a strictly inverse manner. This allows us to add the effects and thus create very subtle echo effects, with multiple responses.

![Dual Delays function scheme.](image)
Setting the delay of the echo

The time interval between the instrument sound and its response (echo) can be controlled with the STEPS window.

The unit of measurement is the sequencer step, which is to say a 16th of a bar (or semi-quaver).

Configuration of time between two echo effects.

In a configuration where the left window is set to number 3 and the right to 5,

- The time between the sound and the response is 3 steps, or 3/16ths of a bar on the left speaker.
- The time between the sound and the response is 5 steps, or 5/16ths of a bar on the right speaker.

Setting echo on a track

It is possible to configure the volume of the echo differently, and thus the number of audible repetitions, for the right or left tracks (or speakers).

To do this, you must use the RIGHT potentiometer of the RIGHT delay and the LEFT potentiometer of the LEFT delay.

In these cases, the more you open the potentiometer towards the right, the more the duration of the audible echoes will increase. When this potentiometer is set to 0, the delay will send only one audible echo. When set to maximum, the effect will send several echoes of the same sound, the volume of each echo being decreased each time. We thus get the impression of a sound that gradually disappears.

Sending the first delay to the second

The Dual Delays module has another possibility:

It is possible to successively send a sound to the right speaker and then to the left, thus creating a rebound effect on the sound between the right and the left.

To do this, it is necessary to use the LEFT button on the RIGHT delay and the RIGHT button on the LEFT delay.
The 2 potentiometers allowing the creation of a rebound effect.

The LEFT button of the RIGHT delay allows you to send the response from the right track to the left track.

The exact opposite is possible with the other button.

The two potentiometers set the intensity of the response of the opposite channel.

The Dual Delays contextual menu

When you apply a right click to this module (Ctrl + Click for Mac), you will access a contextual menu:

- **Edit > Control**: opens an editor for the module continuous controllers.
- **Help**: sends you straight to the help for the module.
- **Add a column**: adds a column to the rack.
- **Add a line**: adds a line to the rack.
- **Remove module**: removes the module from the rack.
- **Effect controls**: displays or hides the effect sends in the rack.
Presentation of the Flanger

Concept:

Here, we also use a signal delayed in relation to the input signal to add it to the initial signal.

The flange is the cycle which consists of shifting the duplicated signal more and more, before bringing it back into phase with the original signal.

Controllers:

- The **STEPS** controller located on the right allows you to set the flange cycle duration.
- The **WIDTH** potentiometer sets the flange amplitude.
- The **FEEDB** potentiometer sets the retroaction value, i.e. the percentage of the duplicated signal reintegrated at the beginning of the signal.

The Flanger contextual menu

When you apply a right click to this module (Ctrl + Click for Mac), you will access a contextual menu:

- **Edit > Control**: opens an editor for the module continuous controllers.
- **Help**: sends you straight to the help for the module.
- **Add a column**: adds a column to the rack.
- **Add a line**: adds a line to the rack.
- **Remove module**: removes the module from the rack.
- **Effect controls**: displays or hides the effect sends in the rack.
Presentation of the LP Filter

Concept:

This is a low-pass resonant filter. The LPFilter effect offers two real-time controllers:

• the cut-off frequency
• the filter resonance

An LCD screen shows in real-time the frequency response curve in function with these two parameters.

Controllers:

• The CUT OFF button sets the value of the cutoff frequency. Frequencies above the cutoff frequency will be filtered.
• The RES button allows you to set a value for the filter resonance.

The LP Filter contextual menu

When you apply a right click to this module(Ctrl + Click for Mac), you will access a contextual menu:

• Edit > Control: opens an editor for the module continuous controllers.
• Help: sends you straight to the help for the module.
• Add a column: adds a column to the rack.
• Add a line: adds a line to the rack.
• Remove module: removes the module from the rack.
• Effect controls: displays or hides the effect sends in the rack.
Presentation of Reverb

Concept:

The Reverb module allows us to submerge an instrument in a sonic ambiance, which simulates the feeling of different rooms.

Controllers:

Choice of room type

A click on the arrows ▼ or ▲ of the Room selector gives you your pick of the rooms available. The name shown suggests the type of ambiance recreated:

- Small: Room with small dimensions, normally not very reverberant, but with configuration, it creates unusual effects.
- Medium: Room with medium dimensions. Ideal for vocals and percussion.
- Large: Very large room. The reverb is long, unreal.
- Cathedral: Imagine an enormous cathedral, cold. The voice gets lost, the harmonies intertwine...
- Tunnel: We're all tempted to shout while passing through a tunnel.

Configuration of reverberation time

The Decay fader lets us configure the reverb time, which is to say the time the sound takes to diminish, after the source is killed.

Configuration of the precision

The Diffuse fader permits us to make the sound either very close and precise, or on the other hand, distant and loose.

Configuration of the ambiance

The pad allows an easy configuration of the ambiance and sonar color of the room used:

- Top left, the sound is clear, precise, and the resonance is also clear.
- Top right, the sound is still clear, but the resonance is muffled (the walls have a tendency to very quickly dampen the resonance).
- Bottom left, the walls are totally absorbent, the resonance remains clear.
- Bottom right, the walls are absorbent and the resonance is muffled.
The Reverb contextual menu

When you apply a right click to this module (Ctrl + Click for Mac), you will access a contextual menu:

- **Edit > Control**: opens an editor for the module continuous controllers.
- **Help**: sends you straight to the help for the module.
- **Add a column**: adds a column to the rack.
- **Add a line**: adds a line to the rack.
- **Remove module**: removes the module from the rack.
- **Effect controls**: displays or hides the effect sends in the rack.
Presentation of the Ring Mod

This effect is a ring modulator.

Concept:

Ring Mod allows you to apply a vibrato to the signal entering the effect. Vibrato is a cyclic modulation applied to the tone of a signal. The speed of this vibrato could be set at a fast speed to give a metallic sound to the signal. The speed and the width of the vibrato can be modulated in real-time.

Controllers:

- The potentiometer called **WIDTH** modulates the width of the vibrato. To put it another way, it changes the intensity of the effect.
- The potentiometer called **SPEED** allows us to set the oscillation frequency of the vibrato. If you turn this controller to a high value, you will get a deformed sound and the results can be interesting.

The oscilloscope on the right allows the real-time visualization of the output signal after the effect has been applied.

The Ring Mod contextual menu

When you apply a right click to this module (Ctrl + Click for Mac), you will access a contextual menu:

- **Edit > Control**: opens an editor for the module continuous controllers.
- **Help**: sends you straight to the help for the module.
- **Add a column**: adds a column to the rack.
- **Add a line**: adds a line to the rack.
- **Remove module**: removes the module from the rack.
- **Effect controls**: displays or hides the effect sends in the rack.
Presentation of the Seq Filter

This is a particularly interesting and original effect. It allows you to apply a different cut off to each of the 16 beats of the bar.

Concept:

The sound of each of the 16 beats is modulated by a band-pass filter. The cut-off frequency of each filter enables the modification the 16 sliders.

The first slider concerns the sound received on the first beat of the bar, the second, the sound received on the second beat of the bar, and so forth.

Contoller:

The potentiometer called RES allows you to modulate the resonance value of the filter. The resonance automatically sets the filter width (an algorithm calculates and selects the best width).

The pattern selector on the left of the RES button lets us use one of 8 predefined configurations.
As is the case with the instruments, it is possible to create your own patterns. To do this we just need to click on the desired pattern number and adjust the 16 slider levels. The changes are automatically recorded into the pattern. The pattern changes are recordable in real time on the sequencer.

The Seq Filter contextual menu

When you apply a right click to this module (Ctrl + Click for Mac), you will access a contextual menu:

- **Edit > Control**: opens an editor for the module continuous controllers.
- **Help**: sends you straight to the help for the module.
- **Add a column**: adds a column to the rack.
- **Add a line**: adds a line to the rack.
- **Remove module**: removes the module from the rack.
- **Effect controls**: displays or hides the effect sends in the rack.
What is a Vocoder?

The vocoder is an effect which became popular during the 70's for transforming a speaking or singing voice to a synthetic voice (notably, the famous robot voice). In the present day it can be found in all musical styles which use electronic instruments (for example groups like Kraftwerk, Earth Wind and Fire, Herbie Hancock, Stevie Wonder...).

It was brought back to life in house and techno by groups like Daft Punk and Stardust (no need to talk about “Around the world” or the recent “One more Time”!) like many other “vintage” technologies. It has now become one of the essential elements of the French house sound (the “French touch”).

On top of this, new virtual and computer technologies allow an easier and above all else cheaper access to vocoder effects! In fact the most basic hardware vocoders are around the 1400 US$ (For example the vocoder Korg VC10 introduced in 1978).

Basics

The vocoder is an effect which allows us to modify the spectrum of the internal sound synthesizer in function to the spectrum of the input signal. As a general rule, the input signal being a voice, the vocoder will filter the sound of the internal synthesizer in a manner so that it follows the spectrum of the voice as well as all of the articulations. Thus as output we get a synthetic voice where the tone and note will depend only on the notes produced on the vocoder synthesizer. The speed of the following of word articulation can be set with the smooth button which allows us to make the articulation variations more or less smooth.
Thus the vocoder lets us make the synthesizer talk, but how do we make it sing?

### Note patterns and sound presets

- Firstly, don't forget to put the EZtrack module into your studio: you will use it to record your voice. It is important to point out that the signal recorded on EZtrack will be placed BEFORE entry into the vocoder! To record the vocoded signal, do it with the RECORDER. You can also use voice samples on H30+ and why not try other sound sources: try for example sending drum rhythms to the vocoder!
- Open the vocoder effect send and close the dry button of the sampler
- On the vocoder, place one or more notes (up to 8 notes at the same time) onto the keyboard on the bottom right of the effect,
- Select one of the 10 synthetic sound presets
- Say a few words into the mic connected to the input of your soundcard (use the mic input!), via EZtrack.
- To hear your voice in real time on EZtrack, you just have to click on the Thru button. (If your sound card allows it, it is recommended to use ASIO to have lower latency).

Your words will follow the note (or notes) played by the keyboard and will have the sound produced by the vocoder synthesizer. This is probably the simplest method of use as you don't need to know how to sing into the mic! To create a melody or a series of chords you just need to add several patterns to the studio sequencer. You can create up to 8 different patterns.

Know also that with this mode, the chords created will follow the tone changes of the Kepler module.

### The synthesizer

The settings of the internal synthesizer start with the preset selector which provides the base sound. The control surface allows recordable real-time modifications of certain synthesizer parameters. The mode button allows us to choose a visualization of the modification surface from four possibilities: filter, mix, tune, LFO. The modifications recorded in a surface will remain active even when another visualization has been selected.

- **Filter**: Modification of the synthesizer output filter. This filter is a low pass resonant filter where the cut off frequency (horizontal) and the resonance (vertical) are modifiable.
- **Mix**: Modification of the mix of the synthesizers oscillators. There are two oscillators where the mix is horizontal and a noise generator where the mix is vertical to the control surface.
- **Tune**: Modification of the tuning of the second oscillator. In horizontal, the fine tune of the second oscillator is modified by a tone more or less. In vertical, it is the octave of this oscillator which is affected (two octaves below, one octave below, same octave, a fifth above, an octave above, an octave and a third above).
- **LFO**: Modification of the LFO characteristics applied to certain parameters of the synthesizer. The LFO is applied on top of the eventual modifications brought by the control surface. The control surface horizontally commands the oscillation frequency and vertically controls the amplitude.
• **The keyboard** allows the programming of the chord that the synthesizer will follow for the selected pattern. Up to 8 notes can be used, the two arrows on the left allow the choice of octave for the keyboard. MIDI programmable (Ctrl + click), a new note is launched upon the reception of an ON note, the OFF notes are not taken into account, which avoids the necessity to keep the note pressed manually.

• The **mix** button allows the mixing of the clean voice signal (audio input) and the sound of the internal synthesizer. By turning the button fully to the left, you get the clean voice, in the middle we have the vocoded voice, and fully to the right the internal synthesizer.

• The **smooth** button allows the setting of the intelligibility of the of the articulated vocoded voice (the more you turn it to the right the less precise the articulation)

To save your own presets, set the control surface to the desired values and select the preset upon which you wish to save with the right mouse button.

---

**The Vocoder contextual menu**

When you apply a right click to this module (Ctrl + Click for Mac), you will access a contextual menu:

• **Edit > Control**: opens an editor for the module continuous controllers.
• **Help**: sends you straight to the help for the module.
• **Add a column**: adds a column to the rack.
• **Add a line**: adds a line to the rack.
• **Remove module**: removes the module from the rack.
• **Effect controls**: displays or hides the effect sends in the rack.
ARTURIA END USER LICENSE AGREEMENT

NOTICE TO END USER: CAREFULLY READ THE FOLLOWING LEGAL AGREEMENT. USE OF THE SOFTWARE PROVIDED WITH THIS AGREEMENT (THE "SOFTWARE") CONSTITUTES YOUR ACCEPTANCE OF THESE TERMS. IF YOU DO NOT AGREE TO THE TERMS OF THIS AGREEMENT, PROMPTLY RETURN THE SOFTWARE AND THE ACCOMPANYING ITEMS (INCLUDING WRITTEN MATERIALS AND CONTAINERS) TO THE LOCATION WHERE YOU OBTAINED THEM FOR A FULL REFUND.

1. License Grant.
ARTURIA S.A. ("ARTURIA") grants to you (either as an individual or entity) a personal, non-transferable, and non-exclusive license to use the copy of the object code version of the SOFTWARE recorded on the media provided in this package. The term of this agreement and the above license will be for the duration of Arturia's copyright in the SOFTWARE; provided, that such term shall automatically expire if you breach any provision herein. Upon termination of this license, you shall return the original and all copies of the SOFTWARE and documentation to ARTURIA or the place where you obtained the PACKAGE, or certify to ARTURIA that you have destroyed the original and all copies of the SOFTWARE and documentation in your possession and within your control. You agree you will not copy the SOFTWARE except as necessary to use it on a single computer system. You agree that you may not copy the written materials accompanying the SOFTWARE. You may assign your rights under this Agreement to a third party who agrees in writing to be bound by this Agreement prior to the assignment and provided that you transfer all copies of the SOFTWARE and related documentation to the third party or destroy any copies not transferred. Except as set forth above, you may not assign your rights under this Agreement.

2. Copyright.
You acknowledge that no title to the intellectual property in the SOFTWARE is transferred to you. You further acknowledge that title and full ownership rights to the SOFTWARE will remain the exclusive property of ARTURIA or its suppliers, and you will not acquire any rights to the SOFTWARE except as expressly set forth above. You agree that any copies of the SOFTWARE will contain the same proprietary notices which appear on and in the SOFTWARE.

3. Reverse Engineering.
You agree that you will not attempt, and if you are a corporation, you will use your best efforts to prevent your employees and contractors from attempting, to reverse compile, modify, translate, or disassemble the SOFTWARE in whole or in part.

4. Limited Warranty.
ARTURIA warrants that the media contained in this package is free from any physical defects for a period of ninety (90) days from the date of purchase ("Limited Warranty"). ARTURIA DOES NOT WARRANT THAT THE SOFTWARE IS ERROR FREE. EXCEPT FOR THE FOREGOING LIMITED WARRANTY, ARTURIA MAKES NO OTHER EXPRESS, IMPLIED OR STATUTORY WARRANTIES AND SPECIFICALLY DISCLAIMS ANY WARRANTIES AS TO THE PERFORMANCE OF THE SOFTWARE, NON-INFRINGEMENT OF THIRD PARTY RIGHTS, MERCHANTABILITY, OR FITNESS FOR A PARTICULAR PURPOSE. SOME JURISDICTIONS DO NOT ALLOW THE EXCLUSION OF IMPLIED WARRANTIES OR LIMITATIONS AN HOW LANG AN IMPLIED WARRANTY MAY LAST, OR THE EXCLUSION OR LIMITATION OF INCIDENTAL OR CONSEQUENTIAL DAMAGES, SO SUCH LIMITATIONS OR EXCLUSIONS MAY NOT APPLY TO YOU. AS TO ANY IMPLIED WARRANTY WHICH MAY NOT BE DISCLAIMED UNDER APPLICABLE LAW, THE DURATION OF SUCH WARRANTY IS 90 DAYS FROM THE DATE OF DELIVERY. THIS WARRANTY GIVES YOU SPECIFIC LEGAL RIGHTS AND YOU MAY ALSO HAVE OTHER RIGHTS WHICH VARY FROM JURISDICTION TO JURISDICTION.

5. Customer Remedies.
Arturia's entire liability and your sole and exclusive remedy shall be, at Arturia's option, to (a) replace defective media or (b) authorize a refund, so long as the SOFTWARE, documentation and media are returned to ARTURIA with a copy of your receipt. This Limited Warranty is void if a defect hat resulted from accident, abuse, or misapplication. Any replacement media will be warranted for the remainder of the original warranty period.

In the event of invalidity of any provision of this Agreement, the parties agree that such invalidity shall not affect the validity of the remaining portions of this Agreement.
7. No Liability for Consequential Damages.
IN NO EVENT SHALL ARTURIA BE LIABLE TO YOU FOR ANY CONSEQUENTIAL, SPECIAL, INCIDENTAL OR INDIRECT DAMAGES OF ANY KIND ARISING OUT OF THE USE OF THE ARTURIA SOFTWARE, EVEN IF ARTURIA HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. IN NO EVENT WILL ARTURIA’S LIABILITY FOR ANY CLAIM, WHETHER IN CONTRACT, TORT OR ANY OTHER THEORY OF LIABILITY, EXCEED THE LICENSE FEE PAID BY YOU.

8. Export.
You agree that you will not export or re-export the SOFTWARE without the appropriate United-States or foreign government licenses and the express written permission of ARTURIA.

ADDITIONAL STATEMENTS REGARDING STORM HALL

9. What Storm Hall is.
Under the name Storm Hall are gathered different interactive features which are part of the SOFTWARE. When opening the Storm Hall dedicated window in the SOFTWARE, the user can access tips and news posted on the Internet, chat with other users, send to specific users some music material, access music material on other users’ computers. In that regard, Storm Hall is an integrated browser and communication system provided by Arturia S.A. to enable Storm Music Studio users to locate and exchange music material and information. By Music Material, one must understand, basic structures such as patterns, presets and loops allowing to create a song in Storm Music Studio. In addition, Music Material also means entire songs in .stm format, the dedicated format for songs composed in Storm Music Studio. A pattern is a short melody programmed for a specific instrument in Storm Music Studio. A preset is a general tuning of the different controllers the user can access on each instrument and effect in Storm Music Studio. Presets are in .stmpre format. A loop is a short audio sample in MP3, Wave, AIFF. Loops cannot exceed 10 seconds in the communication through Storm Hall. Storm Hall is based on a proprietary protocol designed by Arturia S.A. to allow Storm Music Studio users to communicate through Peer to Peer architecture. This protocol has been conceived to help Storm Music Studio users create music and protect them from illegal behavior such as exchange of entire songs in MP3 format, exchange of entire movies, dissemination of viruses.

10. Violation of Copyrights.
PLEASE NOTE THAT ARTURIA RESPECTS THE RIGHT OF COPYRIGHT OWNERS AND IS FULLY COMMITTED TO PROTECT THEIR RIGHTS. ARTURIA EXPECTS ALL STORM MUSIC STUDIO DESKTOP USERS TO DO THE SAME. WE, THEREFORE, ASK YOU TO PAY SPECIAL ATTENTION TO AVOID VIOLATING COPYRIGHT LAWS AND REGULATIONS. AS A CONDITION TO USE THE ARTURIA PRODUCTS AND SERVICES, YOU MUST AGREE THAT YOU WILL NOT USE STORM MUSIC STUDIO TO INFRINGE THE INTELLECTUAL PROPERTY OR OTHER RIGHTS OF OTHERS IN ANY WAY. UNAUTHORIZED COPYING, DISTRIBUTION, MODIFICATION, PUBLIC DISPLAY, OR PUBLIC PERFORMANCE OF COPYRIGHTED WORKS IS AN INFRINGEMENT OF THE COPYRIGHT HOLDERS’ RIGHTS. Storm Music Studio users should be aware that some MP3, wave, aiff and stm files may have been created or distributed without the authorization of the copyright owner or as authorized by law. As a condition to your account with Arturia, you agree that you will not use the Storm Hall service to infringe the copyrights or other intellectual property rights of others in any way. Arturia reserves the right to terminate the account of a user and to block use of the Storm Hall service permanently in appropriate circumstances upon any single infringement of the rights of others in conjunction with use of the Storm Hall service; or for those users identified as repeat infringers; or if Arturia believes the user’s conduct is harmful to the interests of Arturia, its affiliates, or other users; or for any other reason in Arturia’s sole discretion, with or without cause. Without limiting the generality of the foregoing, Arturia will terminate any user whom it determines is intentionally attempting to evade Storm Hall’s mechanism for excluding (from the Storm Hall users file indexes) file names identified as containing unauthorized materials, including evasion by repeatedly encoding or otherwise obfuscating filenames or posting methods of evasion to Storm-Hall forums.

11. Copyright Owners.
Upon proper notice to Arturia, Arturia is ready and willing to use its file name filtering technology to prevent access through the Storm Hall system to any work that a copyright owner or its duly authorized agent claims to own or control. To implement this exclusion, however, we need copyright owners’ assistance. Owners must send to us a notice. To send us a complying notice, you should write to copyright@arturia.com and ask for the more information on how to present your request. In addition, Arturia will conduct regular random tests on files shared in Storm Hall to define if these files are subject to copyright protection.
12. Terms of services.

If you are an adult, to use Storm Hall, you must first: (a) read and accept the SOFTWARE License Agreement of which this Notice and Terms of Service are part, (b) agree to be bound by the terms of that License by pressing the 'Yes' button on the SOFTWARE installation screen and (c) pay the applicable fees, if any. If you are a minor you will become eligible to use Storm Hall upon your parent: (a) reading and accepting the SOFTWARE License Agreement of which this Notice and Terms of Service are part, (b) agreeing to be bound by the terms of that license by pressing the 'Yes' button on the SOFTWARE installation screen and (c) paying the applicable fees, if any. You understand and agree that Storm Hall is provided "AS-IS" and that we assume no responsibility for the failure or inaccuracy of Storm Hall. You are responsible for paying all applicable taxes and for all hardware, software, service and other costs you may incur in connection with your use of Storm Hall, and providing all equipment and software necessary to connect to our web site and to use Storm Hall via the Internet. We may add, delete or change some or all of our services provided in connection Storm Hall at any time. This may include download of necessary software modules. Any new features that augment or enhance Storm Hall will be subject to these notices, terms and conditions and will also be subject to all other applicable Storm Hall policies, terms, notices and conditions as discussed above. We may establish general practices and limits concerning use of Storm Hall. For example, we may limit the number of files that you may make accessible to other Storm Hall users or the number of files of other Storm Hall users that you may access. You agree to accept these general practices and limits as they may be in effect from time to time. In addition, we reserve the right at any time and from time to time to modify or discontinue, temporarily or permanently, Storm Hall (or any portion thereof), or your access to Storm Hall (or any portion thereof), for any reason or no reason, with or without notice. You agree that we will not be liable to you or to any third party for any modification, suspension or discontinuance of Storm Hall or your access to Storm Hall.


ARTURIA HAS MADE ALL POSSIBLE EFFORTS TO AVOID COPYRIGHT INFRINGEMENT THROUGH STORM-HALL, ESPECIALLY BY LIMITING THE TYPE OF FILE FORMATS AND THE LENGTH OF THE AUDIO FILES USERS CAN SHARE OR SEND TO EACH OTHER. ARTURIA WILL MAKE ALL REASONABLE EFFORTS TO CONTROL OR HAVE KNOWLEDGE OF ANY OF THE AVAILABLE CONTENT SHARED THROUGH STORM-HALL. ARTURIA CANNOT CONTROL OR HAVE KNOWLEDGE OF ANY OF THE CONTENT SENT FROM ONE USER TO THE OTHER ONE THROUGH STORM HALL CHAT SERVICES. In any case, Arturia does not guarantee the accuracy, integrity, quality or legality of such content. You may be exposed to content that is offensive, indecent or objectionable. Under any circumstances, Arturia will not be liable in any way for any errors or omissions in any content, or for any loss or damage of any kind incurred as a result of any content transmitted via the Service. You agree to not use the Service to: Transmit any content that is unlawful, harmful, threatening, abusive, harassing, defamatory, vulgar, obscene, invasive of another's privacy, hateful, or racially, ethnically or otherwise objectionable; Harm minors in any way; Impersonate any person or entity or falsely state or otherwise misrepresent your affiliation with a person or entity; Forge headers or otherwise manipulate identifiers in order to disguise the origin of any content transmitted through the Service; Transmit any content that you do not have a right to transmit under any law or under ; contractual or fiduciary relationships (such as inside information, proprietary and confidential information learned or disclosed as part of employment relationships or under nondisclosure agreements); Transmit any content that infringes any patent, trademark, trade secret, copyright or other proprietary rights ("Rights") of any party; Transmit any material that contains software viruses or any other computer code, files or programs designed to interrupt, destroy or limit the functionality of any computer software or hardware or telecommunications equipment; Disrupt the normal flow of dialogue, cause a screen to "scroll" faster than other users of the Service are able to type, or otherwise act in a manner that negatively affects other users' ability to engage in real time exchanges; Interfere with or disrupt the Service or servers or networks connected to the Service, or disobey any requirements, procedures, policies or regulations of networks connected to the Service; Intentionally or unintentionally violate any applicable local, state, national or international law, including securities exchange and any regulations having the force of law; "Stalk" or otherwise harass another; or Collect or store personal data about other users ; Advertise or offer to sell or buy any goods or services; Restrict or inhibit any other user from using and enjoying its rights in the Communication Services. You acknowledge and agree that Arturia may preserve content and may also disclose content if required to do so by law or in the good faith belief that such preservation or disclosure is reasonable necessary to: (a) Comply with legal process; (b) Enforce the License Agreement; (c) Respond to claims that any content violates the rights of third-parties; or (d) Protect the rights, property, or personal safety of Arturia, its users and the public. (e) Monitor network traffic or make search requests in order to accumulate information about individual users.
14. Registration.
Arturia asks that you register your copy of the SOFTWARE. In the registration process, we ask a few questions about you. Your license number, name, surname, address, e-mail address and seed number - The seed number is a key calculated by the software based on your computer configuration - are the only compulsory information demanded. In addition, when you connect to Storm-Hall for the first time, we will ask you what is the speed of your Internet connexion. We ask your name and address so we can send you the upgrade for the SOFTWARE by postal mail in case it is necessary. We ask your e-mail address to be able to contact you via email if the need arises. We calculate a seed number from your computer to protect the SOFTWARE against piracy. We want to know the speed of your connection to the Internet because your participation in the Storm Music Studio community depends on our ability to help connect you to other users across the Internet. As you may decide to do not reveal your identity, you are not obliged to give personally identifiable information during the entire process of registration. In any case, Arturia is committed to ensuring that you have appropriate control over your information. We take security measures to protect the Personally Identifiable Information and do not transfer or sell our databases to any private individual or company.